MSA Storage

Unable to upgrade MSA 1050 Firmware

 
INFRA-S2I
Occasional Advisor

Unable to upgrade MSA 1050 Firmware

Hello,

I'm trying to update an MSA 1050 Firmware. Actual version is VE100R002 and I'm trying to update to VE270R001-01 version, at least.

I execute the firmawre update executable file from a Windows 2016 Server, with full network access to the MSA, using manage account (after restore defaults command). There's no disk configuration done in the MSA. The MSA is configured in Single Controller mode.

After 1 hour, the update firmware failed with an error "Controller version Mismatch!!".

In the log file, I've also found the following error :

   [0248] UPLOAD: FW Binary file size: 51288736 bytes

   [0248] ERROR:UPLOAD: Curl API returned with : 9 *****

Last thing I tried, I can make a FTP connection to the controller using manage account but I cannot put a file on the controller, with an error message "553 Unable to create file xxx (write protected)".

It seems the FTP part of the controller is in read-only mode, tha'ts may be why the update cannot upload the firmware file to the controller...

Thanks for your help.

6 REPLIES 6
support_s
System Recommended

Query: Unable to upgrade MSA 1050 Firmware

System recommended content:

1. HPE MSA 1050 User Guide

2. HPE MSA 1050/2050 SMU Reference Guide

 

If the above information is helpful, then please click on "Thumbs Up/Kudo" icon.

 

Thank you for being a HPE community member.


Accept or Kudo

Cali
Honored Contributor

Re: Unable to upgrade MSA 1050 Firmware

Hi,

I would recommend the MSA Health Check: MSA Health Check | HPE Services  

check firmware-upgrade-health
show protocols
show version

 

Cali


======================
I'm not an HPE employee, so I can be wrong.
INFRA-S2I
Occasional Advisor

Re: Unable to upgrade MSA 1050 Firmware

Hi,

After MSA Health check :

Unhealthy :

- Controller Firmware Versions Match (in Firmware Inventory : Enclosure 1 - Controllers   Not Present (1), VE100R002 (1) )

- Firmware Versions Up to Date

- Notifications Turned On

- Scrubbing Enabled

- Unsecure Protocols Check

Warning :

- Memory Card Events Issues (Memory Card Event Code 481 found in event list)

Remaining checks are Healthy.

 

Commands result :

check firmware-upgrade-health :

Upgrade Health
---------------------------------
Pass
---------------------------------
Success: Command completed successfully. (2021-12-15 14:33:09)

show protocols

Service and Security Protocols
------------------------------
Web Browser Interface (HTTP): Disabled
Secure Web Browser Interface (HTTPS): Enabled
Command Line Interface (Telnet): Enabled
Secure Command Line Interface (SSH): Enabled
Storage Management Initiative Specification (SMI-S): Enabled
Unsecure Storage Management Initiative Specification (SMI-S 5988): Disabled
Service Location Protocol (SLP): Enabled
File Transfer Protocol (FTP): Enabled
Secure File Transfer Protocol (SFTP): Enabled
Simple Network Management Protocol (SNMP): Disabled
Service Debug (Debug): Disabled
In-band SES Management (SES): Disabled
Activity Progress Reporting (activity): Disabled

Service Ports
-------------
SSH Port: 22
SFTP Port: 1022

Success: Command completed successfully. (2021-12-15 14:33:31)

show version

Controller A Versions Controller B Versions
--------------------- ---------------------
Bundle Version: Not Present VE100R002
Build Date: Not Present Thu Aug 3 13:01:06 MDT 2017

Success: Command completed successfully. (2021-12-15 14:34:30)

Thanks.

JonPaul
HPE Pro

Re: Unable to upgrade MSA 1050 Firmware

@INFRA-S2I   It appears that your system is in a 'non-standard' configuration.
Why is controller A reporting firmware bundle 'not present'?
check firmware-upgrade-health  should fail if one controller is unavailable.
All MSA 1050 systems initially shipped with dual controllers and the Smart Component and other parts of the upgrade process rely on dual controllers.
If you system only has one working controller, I would suggest moving that controller into the top slot to become the A controller.  You might have better luck with FW update using the SMU or FTP with the controller in slot A.

I work for HPE
INFRA-S2I
Occasional Advisor

Re: Unable to upgrade MSA 1050 Firmware

@JonPaul, we removed tha controller A from the MSA because we cannot either set an ip address from the contoller b (controller A stays with default IP address), either log in into controller A, either restart it from controller B (communication failure). So we decide to remove it and work only with controller B.

I think we tried to put controller B in the top slot but without success (no response to ping on lan).

I will make some more testes next week and i will keep you inform on it.

I really don't know what happened to this MSA... We just reconnect it last week, after 1 year being shutdown and disconnected from the network and the power.

Thanks and regards.

tapelibraryfixr
Trusted Contributor

Re: Unable to upgrade MSA 1050 Firmware

i see this quite often on msa controllers, more often than not it an issue with the management controller side of the controller itself.