MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

msa 2040 is not connect to hba sn1000q 16 gb/s

 
reza1
Occasional Contributor

msa 2040 is not connect to hba sn1000q 16 gb/s

hello.

i have msa 2040 (k2r80a) and sfp transiver is c8r24a 16 gb/s on it, and i have dl380 gen 9 with hba card sn1000q 16 gb/s(qw972a), when i connect transiver to hba by fiber channel cabel is not showing initiator in smu and host section in msa 2040.

but when i use hba 82q(aj764a) 8gb/s the connection is ok and initiators is show in smu

 

4 REPLIES 4
Venkat-V
HPE Pro

Re: msa 2040 is not connect to hba sn1000q 16 gb/s

Hi Reza,

Could you please let me know the below details to check further on this,

1) Host Operating System Version

2) FC HBA(qw972a) Driver and Firmware Version.
3) Is it a direct connection or via FC Switch?

Regards,

Venkat.

I am an HPE Employee

Accept or Kudo

Shivam1
HPE Pro

Re: msa 2040 is not connect to hba sn1000q 16 gb/s

Hi,

 

Log into the CLI of the MSA and run the following commands :

 

set host-parameters controller both fibre-connection-mode auto speed auto

 

This command shall enable all the FC enabled ports on both controllers  to use loop/P2P connection depending on the mode of FC conenction and auto negotiate the speed.

 

I am an HPE Employee

If this information helps you with your issue, please click the thumb to register a Kudo.
Also, if it resolves your issue, please consider marking it as an Solution Accepted.

 

Accept or Kudo

Shawn_K
HPE Pro

Re: msa 2040 is not connect to hba sn1000q 16 gb/s

Hello,

When you first connected your 8G HBA the driver automatically loaded within the host OS along with the QLogic Connect utiltiy. WIth the SN1000G HBA the driver on some OS versions does not automatically load. You should try installing the SN1000G back into the server, then load the correct driver for your OS. Once the SN1000Q driver has been loaded confirm on the QLogic Connect utility the HBA can be seen and configured.

If the SN1000Q was previously used in another configuration or server be sure to clear all the old configuration. That HBA can carry the previous configuraiton over which might not be compatable with the MSA array.

Once the driver is loaded and the HBA is working correctly on the host side, check the MSA and be sure the FC host ports being used are in auto mode. At this point you should be able to see the initiators in SMU and perform mapping.

Cheers,

Shawn

Accept or Kudo

SahanaR
HPE Pro

Re: msa 2040 is not connect to hba sn1000q 16 gb/s

Hello @reza1,

 

Resolution::

  1. In SMU, change the topology between loop and PTP or Auto ( sometimes PTP or Loop will not be listed) Some HBA needs different topology than standard one
  2. If no luck, toggle the host port speed between 8gb, 16Gb or auto
  3. If no joy, then upgrade HBA drivers and firmware to make it compatible with the higher speed spf.

 

I hope this helps:)

 

 

Sahana@R

Accept or Kudo