MSA Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

need help with MSA1000 and HBA FCA2214 install

 
CA1112893
Occasional Contributor

need help with MSA1000 and HBA FCA2214 install

Ok everyone, I am hoping you can lead me in the right direction. I am new to Sans, just purchased the equipment listed in the subject and this will go on a DL380 G2 Server.

So I follow the instructions to the tee and my FCA2214 installs as a Qlogic QLA23xx Fibre Channel Adapter. Is this correct? Everytime I boot up the MSA1000 and I get a problem saying that the Fiber link is dead. Does anybody have any dummy step by step instructions to help me install this stuff correctly? The instructions make sense to me, they just don't seem to be leading me in the right direction.

Also, after the card is installed correctly, is there anything special that I need to do to get the MSA1000 online, besides configure the array?


Thanks

Kev
5 REPLIES 5
Uwe Zessin
Honored Contributor

Re: need help with MSA1000 and HBA FCA2214 install

Kevin,
what does your MSA1000 look like - I assume the 'dead' message is on the alphanumeric display of the MSA1000, correct?.

Does it have 2 controllers in their bays at the front? Does every controller have either an I/O module, a 2/3-hub or an embedded fibre channel switch in the rear bay?
.
CA1112893
Occasional Contributor

Re: need help with MSA1000 and HBA FCA2214 install

Well, our MSA only has 1 card on the front, plus it only has a single fiber port in the back.

Playing with it again this morning, for some reason my HBA keeps blinking orange and the MSA has the error on front saying516 Febre Sub-System link failure and the fibre link in the back has no lights lit up.

Thanks
Kev
Uwe Zessin
Honored Contributor

Re: need help with MSA1000 and HBA FCA2214 install

Ok, if you have a module with a single LC connector at the back, then this is an I/O module. The I/O module usually goes to an external switch.

If you connect your server directly to the I/O module you can only run FC_AL (Fibre Channel - Arbitrated Loop) protocol. Honestly, I don't know if that is a supported configuration. I don't recall I have ever seen this mentioned in any documentation, but I don't know everything so trying it out will not hurt. You cannot cause any physical damage.

I don't know how your adapter is set up, but the default is that is should try FC_AL first. If you want/have to lock the adapter to run in loop mode - it is the 'Connection Options' entry.

You should also check the 'Data Rate' - per the documentation the default is 1 GBit/sec. I suggest you try this first and lock it to 2 GBit/sec.

I don't know what cable you are using, but you need a crossed one. It might sound silly, but I beleive a check cannot hurt. Me and my colleagues have already debuged some customer's backbone cabling - they had some fibers that were connected incorrectly in the patch panels.

Please get hold of the Installation Guide (AA-RSBMB-TE) - I found a copy here:
http://h20000.www2.hp.com/bizsupport/CoreRedirect.jsp?targetPage=http%3A%2F%2Fh200007.www2.hp.com%2Fbc%2Fdocs%2Fsupport%2FUCR%2FSupportManual%2FTPM_aa-rsbmb-te%2FTPM_aa-rsbmb-te.pdf

It describes how to make the changes. Don't forget to note the old value(s).

You might also want to try the latest firmware if it is not already installed:
http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?pnameOID=315741&locale=en_US&taskId=135&prodTypeId=12169&prodSeriesId=315739

If you get that working, congratulations!

The next step is to make sure your MSA1000 is at a current firmware level:
http://h18000.www1.hp.com/products/storageworks/softwaredrivers/msa1000/index.html


Well, I guess this is enough for now. If this isn't urgent - don't try to hurry. Do one step after the other and write down your steps so you can look over them later. Enjoy the learning!
.
CA1112893
Occasional Contributor

Re: need help with MSA1000 and HBA FCA2214 install

Thank a bunch for the help...so far you have kept me on the right track..for that I owe you a huge thanks.

I did end up having to call HP support to see if they can help me further troubleshoot this. What we have stumbled across is that my problem has got to be the FCA2214 card. Either it is not any good, or I just can not seem to get the correct driver on this card. I have tried several different drivers from HP/compaq and nothing. Can somebody point me in the direction of what driver they are using?

Thanks
Uwe Zessin
Honored Contributor

Re: need help with MSA1000 and HBA FCA2214 install

Hello Kevin,
the second link I posted does have the adapter firmware *and* the drivers as well.

I don't see that you have mentioned the operating system, but for Windows I suggest you try this one:
http://h20000.www2.hp.com/bizsupport/CoreRedirect.jsp?targetPage=ftp%3A%2F%2Fftp.hp.com%2Fpub%2Fsoftlib%2Fsoftware3%2FCOL4500%2Fco-15255-2%2Fcp003973.exe
.