cancel
Showing results for 
Search instead for 
Did you mean: 

Mail stopped working??

SOLVED
Go to solution

Mail stopped working??

Model= HP9000/889/K460 HP-UX 10.2

Mysteriously, I stopped receiving root???s e-mail on 13JUNE. When I look at another machine which is working properly, I see this:

msphbos0ROOT:ps ???eaf | grep sendmail
root 1874 1 0 Mar 26 ? 1:29 sendmail: accepting connections on port 25

When I try the same thing on the bad machine, I see this:

msphnyc1ROOT:ps ???eaf | grep sendmail
root 26759 1 0 08:49:58 ? 0:00 sendmail: accepting connections

Notice that on the bad machine, it does not specify port 25. Could this be my problem?

I have tried a /sbin/init.d/sendmail stop and /sbin/init.d/sendmail start. I have also tried a sendmail ???bd.

Also, I have seen in previous posts that I might have to rm /etc/mail/sendmail.pid, but when I do a ls ???al from /etc/mail, this is all I see:

msphnyc1ROOT:ll
total 144
-r--r--r-- 1 bin bin 948 Jun 7 1996 aliases
-rw-r--r-- 1 root mail 32768 Dec 3 1999 aliases.db
-r--r--r-- 1 bin bin 10203 May 30 1996 mailcap
-r--r--r-- 1 bin bin 27403 Jun 7 1996 sendmail.cf
-r--r--r-- 1 bin bin 702 Sep 22 1999 sendmail.cw
-r--r--r-- 1 bin bin 1002 Jun 7 1996 service.switch


Any idea why my mail is not working?
5 REPLIES
Bruno Vidal
Respected Contributor

Re: Mail stopped working??

Hi,
If you change nothing, it can be coming from the load of your system, sendmail is stopping to treat any mail if load average is bigger than a limit, take a look at:
#uptime
What are the last number, is it bigger than 8 (it is the default limit).

Cheers.

Re: Mail stopped working??

msphnyc1ROOT:uptime
10:18am up 46 days, 8:02, 11 users, load average: 0.33, 0.28, 0.36
Bruno Vidal
Respected Contributor

Re: Mail stopped working??

Your load average is perfect, no problem on this side, you perhaps can try to send yourself an email by using mailx:
#mailx -s "test 1" root << EOF
type your text
EOF

and then just after take a look at /var/adm/syslog/mail.log and search for any explicit error.

cheers.

Re: Mail stopped working??

I tried what you suggested. Here is what the mail.log says:

Jun 24 10:35:28 msphnyc1 sendmail[5531]: KAA05531: from=bkjb830, size=150, class
=0, pri=30150, nrcpts=1, msgid=<200306241435.KAA05531@msphnyc1.>, relay=root@loc
alhost
Jun 24 10:35:29 msphnyc1 sendmail[5532]: KAA05531: to=root, ctladdr=bkjb830 (129
/20), delay=00:00:01, xdelay=00:00:00, mailer=local, stat=Insufficient permissio
n: Error 0
Jun 24 10:35:29 msphnyc1 sendmail[5532]: KAA05531: KAA05532: postmaster notify:
Insufficient permission: Error 0


I see error messages for "insufficient permission". What the heck permissions is this error referring to???

-cd
Bruno Vidal
Respected Contributor
Solution

Re: Mail stopped working??

It seems that something has change on permission for sendmail or in root directory.
So check is sendmail still have the set uid bit:
ls -l /usr/sbin/sendmail
-r-sr-sr-T 1 root mail 970752 Mar 6 13:57 /usr/sbin/sendmail

Or, if you are using in ~root any .forward, check that it is correctly set to only root:

Check also the right in /etc/mail:
ll /etc/mail
total 250
-rw-r----- 1 root sys 835 Apr 26 2002 aliases
-rw-r----- 1 root mail 24576 Mar 11 11:54 aliases.db
-rw-r----- 1 root mail 0 Apr 26 2002 aliases.dir
-rw-r----- 1 root mail 1024 Apr 26 2002 aliases.pag
-rw-r----- 1 bin bin 10203 Oct 27 1997 mailcap
-rw-r----- 1 bin bin 86833 Feb 24 1999 sendmail.cf
-rw-r----- 1 bin bin 727 Apr 26 2002 sendmail.cw
-rw------- 1 root mail 33 Mar 11 11:54 sendmail.pid
-rw-r----- 1 bin bin 1075 Apr 26 2002 service.switch


As you see it is readable only for root -> it is a security check from sendmail to ensure that nobody is changing the rules.

Cheers.