cancel
Showing results for 
Search instead for 
Did you mean: 

No locks available

SOLVED
Go to solution
Sanjiv Sharma_1
Honored Contributor

No locks available

Hi,

I have a N4000/HP-UX11.00.

Today when I login to the system, I am getting the message:
Apr 4 10:37:32 camel sendmail[29731]: KAA29731: queueup: cannot lock tfKAA29731
: No locks available
Apr 4 10:37:32 camel sendmail[29736]: KAA29736: queueup: cannot lock tfKAA29736
: No locks available
Apr 4 10:37:32 camel sendmail[1771]: KAA01771: queueup: cannot lock tfKAA01771:
No locks available
Apr 4 10:39:55 camel sendmail[15915]: KAA15915: queueup: cannot lock tfKAA15915
: No locks available
Apr 4 10:41:02 camel sendmail[18007]: KAA18007: queueup: cannot lock tfKAA18007
: No locks available
Apr 4 10:41:02 camel sendmail[19247]: KAA19247: queueup: cannot lock tfKAA19247
: No locks available
Apr 4 10:43:31 camel sendmail[16416]: KAA16416: queueup: cannot lock tfKAA16416
: No locks available
Apr 4 10:43:38 camel sendmail[17577]: KAA17577: queueup: cannot lock tfKAA17577
: No locks available
Apr 4 10:43:38 camel sendmail[17578]: KAA17578: queueup: cannot lock tfKAA17578
: No locks available
Apr 4 10:43:38 camel sendmail[17576]: KAA17576: queueup: cannot lock tfKAA17576
: No locks available
Apr 4 10:44:21 camel sendmail[2767]: KAA02767: queueup: cannot lock tfKAA02767:
No locks available

What has gone wrong and what needs to be done?

Thanks,

Everything is possible
8 REPLIES
Patrick Wallek
Honored Contributor

Re: No locks available

Sanjiv Sharma_1
Honored Contributor

Re: No locks available

Hi Patrick,

The document given by you talk about HP-UX 10.20 and also I am not getting the error with

# echo test | sendmail -v root@machine.com

It gives the message mail sent.

Everything is possible
John Poff
Honored Contributor

Re: No locks available

Hi,

What is your nflock kernel parameter set for? You might need to increase it and relink your kernel.

JP
Sanjiv Sharma_1
Honored Contributor

Re: No locks available

Hi John,

My nflocks parameter is set to 200.

nfile 114558
nflocks 200
ninode 1666
nproc 1466

What is the advisable nflocks parameter to which I should set?

The no of files in /var/spool/mqueue are 302.


Everything is possible
John Poff
Honored Contributor
Solution

Re: No locks available

If you have over 300 messages, and your nflock is set for 200, I'd suggest at least doubling it to 400. Probably the bigger question is, how many sendmail processes do you have running? It sounds like your system is trying to send some messages and can't send them for some reason. Are those messages all going to the same address? Maybe there is a problem getting those messages sent off of your system?

Since you have to reboot to increase your nflock parameter, you might as well check into the sendmail processes first and see if there is a problem there.

Have fun!

JP
U.SivaKumar_2
Honored Contributor

Re: No locks available

Hi,

Sendmail locks a queue file for processing the mail.

In comparison with nfiles parameter your nflocks parameter value is very less.

you have to Increase the value of nflocks alteast +1000

Also what is the ownership and permissions of /var/spool/mqueue directory ?

regards,

U.SivaKumar


Innovations are made when conventions are broken
T G Manikandan
Honored Contributor

Re: No locks available

The default value of nflocks is 200.

Your messages are related to this parameter in kernel.

YOu need to increase the parameter to 350 or 400.

Thanks
Michael Tully
Honored Contributor

Re: No locks available

Unless you are actually using stacks of emails all the time, be a little weary of increasing kernel parameters for the sake of doing it. In saying that a lot of the time it depends on the applications your running on your system as to what kernel paremeters need increasing. Each increase increases the size of your kernel and also utilises valuable system memory.
Anyone for a Mutiny ?