cancel
Showing results for 
Search instead for 
Did you mean: 

Vacation - second part

SOLVED
Go to solution
enrico.nic
Regular Advisor

Vacation - second part

Hi all
Sorry for the repost but the problem seems to be different from the original one

I am trying to set up the vacation program for a specific user.
Following the manuals:
1) I have created the file .vacation.msg with the following text (just to test the functionality):
From: user@gissi.marionegri.it
Subject: Vacation
X-Delivered-By-The-Graces-Of: the vacation program
Precedence: bulk

I will be out of the office until August 15, 2002.
EOF

The file is created in the home dir of the user "user". Permissions on the file are
-rwxr-xr-x (755)

2) Used (as user "user") the command
# vacation -i
The command creates the files ".vacation.dir" and ".vacation.pag".

3) created (as user "user") a file .forward in the home dir with the following single line:
\user, "|vacation -a user"
Permissions on the file are
-rw------- (600)

All this does not work, it seems to be a problem of sendmail, because instead of a vacation reply I receive a message reporting:

----- The following addresses had permanent fatal errors -----
"|vacation -a user"
(reason: 550 Unsafe for mailing to programs)
(expanded from: )


----- Transcript of session follows -----
550 5.7.1 /home/user/.forward: line 1: "|vacation -a user"... Address is unsafe for mailing to programs
Reporting-MTA: dns; gissi.marionegri.it

In sendmail the restricted sendmail shell (smrsh) was already enabled, and the vacation program had been already copied in the correct directory (sm.bin) where the restricted shell looks for executables. (And that's the reason for not having cited the full path of "vacation" in the command line)

In the sendmail configuration file I haven't found the phrase "is unsafe for mailing to programs"

Could you please help ?

Thank you

Enrico
6 REPLIES
Steven E. Protter
Exalted Contributor

Re: Vacation - second part

I have a wild answer for you.


How about an auto-reject with message in the access database.

email@yourdomain.com REJECT 550 User is on vacation.

Or don't reject, simply reply.

Lots of possibilities.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Rita C Workman
Honored Contributor
Solution

Re: Vacation - second part

Well I did notice you may have mistyped it here...or there....

should be for the .forward

\user, | "vacation user"

Just a thought,
Rita
enrico.nic
Regular Advisor

Re: Vacation - second part

The pipe is in the correct place, although out or inside the double quotes doesn't make a difference - I didn't know that, just from previous replies

Could you explain me better the auto-reply,
SEP ? I don't understand your suggestion

Thank you

Enrico
Rita C Workman
Honored Contributor

Re: Vacation - second part

Try changing the permissions on the .forward file to something more like 644 and see if that helps...

Rgrds,
Rita
Steve Cameron_1
Occasional Visitor

Re: Vacation - second part

Might wanna double-check Rita's first reply (She removed the "-a" too.) Since (from the man page) the "-a" requires an alias in addition to the login name, your command did not specify a login to apply the vacation program to (from the man page, the syntax is "vacation [ [-a alias] ...] login") - you gave "alias" but no "login". Also from the man page, "It is also important to specify the full path for the vacation program". It also notes "there must be no white space between the
| character and the start of the path name".


enrico.nic
Regular Advisor

Re: Vacation - second part

Thank you all, removing the "-a" command option solved the problem.
Magically in the mail.log appeared 2 lines with the message to "|vacation user" and the message to the original sender ... thank you so much.

Enrico