cancel
Showing results for 
Search instead for 
Did you mean: 

top showing sendmail usage

SOLVED
Go to solution
toni osta
Frequent Advisor

top showing sendmail usage

Hi ,
when i lunch the command top , it shows many processes related to sendmail ,
or i did not configure sendmail ,
and it is consuming the memory usage ,
i am trying to stop sendmail by /sbin/init.d/sendmail stop , it gives
stop ... unknown user , and dont give again the prompt ,
the output of top is the folowing 15823 root 148 20 861M 231M sleep 50:38 7.82 7.81 sendmail:
0 ? 1314 root 154 20 906M 899M sleep 57:50 7.73 7.72 sendmail:
1 ? 17979 root 154 20 653M 521M sleep 33:55 7.05 7.04 sendmail:
1 ? 24129 root 148 20 155M 143M sleep 2:16 5.96 5.95 sendmail:
0 ? 51 root 152 20 7848K 6976K run 16:41 5.14 5.13 vxfsd
1 ? 11902 root 198 20 509M 397M run 24:43 4.89 4.88 sendmail:
0 ? 6727 root 134 20 435M 342M run 20:33 4.73 4.72 sendmail:
0 ? 2382 root 154 20 382M 319M sleep 16:20 4.22 4.21 sendmail:
0 ? 6045 root 148 20 15860K 8588K run 0:07 3.81 3.80 sendmail:
1 ? 3820 root 154 20 289M 247M sleep 7:49 3.74 3.74 sendmail:
1 ? 27213 root 148 20 347M 273M sleep 11:38 3.73 3.72 sendmail:
1 ? 13897 root 148 20 215M 176M sleep 4:27 3.42 3.42 sendmail:
0 ? 23700 root 154 20 251M 207M sleep 6:01 3.29 3.29 sendmail:
0 ? 14942 root 154 20 317M 243M sleep 9:01 3.16 3.15 sendmail:
0 ? 3935 root 148 20 186M 162M run 3:10 3.12 3.12 sendmail:
0 ? 14780 root 148 20 83956K 76604K run 1:02 2.93 2.92 sendmail:


Thank you for giving me your oppinion about that:
5 REPLIES
TTr
Honored Contributor
Solution

Re: top showing sendmail usage

> it shows many processes related to sendmail
That's normal if your server is doing a lot of sendmail processing or there is queued email that is being sent out. It is not normal if you are not supposed to be doing a lot of sendmail traffic. In this case either there is something wrong in your configuration or somebody is using your server as a sendmail relay (security issue).
> or i did not configure sendmail ,
Not sure what you are saying.

> i am trying to stop sendmail by /sbin/init.d/sendmail stop , it gives stop ... unknown user

It appears that this command is invoking the sendmail binary and is trying to send an email to a user named "stop". Check out the /sbin/init.d/sendmail script if it is ok or it is corrupted or it is incorrectlry pointing to (or replaced by) the sendmail binary. If the /sbin/init.d/sendmail is bad, you can stop sendmail by running the command "/usr/sbin/killsm". If this fails then you can kill sendmail by finding the sendmail parent process. "ps -ef |grep sendmail" look in the PID and PPID and note which sendmail process is the parent of all the rest. Kill that one and then you can kill the remaining ones.
Steven E. Protter
Exalted Contributor

Re: top showing sendmail usage

Shalom,

You may need to as root issue kill against these processes.

Take a look at your mail.log file in /var/adm/syslog and see what the issue is with sendmail.

Of your server is Internet exposed, you may be being abused. If not, you may simply have a lot of mail that can not be delivered.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
~sesh
Esteemed Contributor

Re: top showing sendmail usage

Try logging in as root and then try to stop the service. If you do not need the sendmail service, then you can stop the service from loading up permanently.

A better option would be to rename the file from under /sbin/rc*.d/ (* corresponds to the runlevel the server normally functions in, try who -r to confirm).

The script will be named something like S***sendmail. Rename it to something like oldS***sendmail (*** could be any number).

Otherwise, simply edit the:
/etc/rc.config.d/mailsvrs
Set the run sendmail option to 0.
Dennis Handly
Acclaimed Contributor

Re: top showing sendmail usage

Try the mailq(1) command to see how many message are waiting to be delivered.

>~sesh: A better option would be to rename the file from under /sbin/rc*.d/
>simply edit the: /etc/rc.config.d/mailsvrs

You should be editing the config files and not changing/removing the rc scripts.
~sesh
Esteemed Contributor

Re: top showing sendmail usage

Dennis: I have come across the suggestion for renaming the rc scripts. I haven't seen any objections for that. That's not to say, 2 wrongs make a right.

But I guess changing the SENDMAIL_SERVER value to 0 should be ok.