cancel
Showing results for 
Search instead for 
Did you mean: 

user unknown

Mohd Rasidi Che Mat
Frequent Advisor

user unknown


we can't send email to xxx@company.com from server1 but email to xxx@hp.com went through. i've checked xxx@company.com is correct as user can receive email from another server.

i found out when sending locally (xxx@company.com), mailer=local & relay=root@localhost:

Aug 17 15:03:24 server1 sendmail[10451]: n7H53OW10451: to=xxx@company.com, delay=00:00:00, mailer=local, pri=0, dsn=5.1.1, stat=User unknown
Aug 17 15:03:24 server1 sendmail[10451]: n7H53OW10451: from=root, size=140, class=0, nrcpts=1, msgid=<200908170503.n7H53OW10451@server1.company.com>, relay=root@localhost


whereas for external email, mailer=relay, relay=smtp_server.company.com:

Aug 17 13:52:36 server1 sendmail[13370]: n7H3qaC13361: to=xxx@hp.com, ctladdr=username (48500/45005), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=120145, relay=smtp_server.company.com. [x.x.x.x], dsn=2.0.0, stat=Sent ( <200908170352.n7H3qaC13361@company.com> Queued mail for delivery)

how to fix it?
4 REPLIES
Steven Schweda
Honored Contributor
Mohd Rasidi Che Mat
Frequent Advisor

Re: user unknown

i closed the other thread. i wanted to add more info but couldn't find it.
Matti_Kurkela
Honored Contributor

Re: user unknown

Your sendmail on server1 is currently configured to assume that mail to xxx@company.com should be directed to user xxx on server1. This is why sendmail chose the local mailer ("mailer=local" in the first log message).

The local mailer noticed that there is no user account named xxx on server1, therefore the mail cannot be delivered.

I guess you mean that all mail addressed to xxx@company.com should go to smtp_server.company.com to be delivered to xxx's central inbox, wherever it may be. Is this correct?

One solution would be to make your server stop pretending that it is "company.com" instead of "server1.company.com", and make smtp_server.company.com understand that all mail addressed to someone@server1.company.com should be delivered just like someone@company.com.

That is, disable the MASQUERADE settings on server1.company.com and make the appropriate configuration changes to smtp_server.company.com.

If you need to hide server1.company.com from the headers of outgoing emails and smtp_server.company.com cannot do it for server1, the problem is a bit harder. The Sendmail book says the macros MAIL_HUB and/or LOCAL_RELAY should do what you need (depending on exactly how you wish the mail to be routed).

At this moment, I don't have access to a HP-UX /etc/mail/sendmail.cf so I cannot verify how (or if) these macros could be activated using the standard HP-UX sendmail.cf file.

If the standard HP-UX sendmail.cf cannot fulfill your requirements, please read /usr/newconfig/etc/mail/cf/README. It has instructions for creating a custom configuration for sendmail.
However, an in-depth understanding of sendmail and/or the Sendmail book from O'Reilly is practically a requirement for that.

MK
MK
Mohd Rasidi Che Mat
Frequent Advisor

Re: user unknown

"I guess you mean that all mail addressed to xxx@company.com should go to smtp_server.company.com to be delivered to xxx's central inbox, wherever it may be. Is this correct?"

yes correct.

tried changed DM, /etc/mail/sendmail.cw, nothing work yet.