Microsoft System Center Integration
cancel
Showing results for 
Search instead for 
Did you mean: 

SNMP not feeding SCOM or SMH

 
curtmcgirt
Advisor

SNMP not feeding SCOM or SMH

i have about 150 servers, 2000, 2003, 2008, all the 2003 and 2008 boxes are on PSP 8.30. on only two 2008 servers, the HP Insight Management Agents are not feeding info to either SCOM or the System Management Homepage. SMH source is blank. if i install the WBEM providers, the SMH gets populated but scom is still missing data, like it shows no info for NIC or ILO. SNMP service is running on both trouble machines.
10 REPLIES
Stuart Cain
Frequent Advisor

Re: SNMP not feeding SCOM or SMH

Can you try the following steps:

1. Ensure the Windows SNMP Service is properly configured & the HP Insight Management Agents are installed if you choose SNMP. Set a Community String.
2. If WMI based instrumentation is preferred make sure the HP Insight Management WBEM Providers are installed.
3. Check the HP ProLiant MP User Guide, section titled: Overriding HP ProLiant Server Management setting for SNMP and WMI management preference to make sure the MP is using the right instrumentation for the server.
4. Confirm the proper data source through SMH (System Management Homepage) either SNMP or WBEM.
curtmcgirt
Advisor

Re: SNMP not feeding SCOM or SMH

my preference is to use SNMP. i have had issues with the wbem providers causing many errors. i'm not sure how to configure the windows snmmp service. but it's running and set to automatic.
curtmcgirt
Advisor

Re: SNMP not feeding SCOM or SMH

the hp insight management agents are installed, as part of PSP 8.30. i have uninstalled and reinstalled them in attempt to fix this but it's still broken.
curtmcgirt
Advisor

Re: SNMP not feeding SCOM or SMH

i should also point out that in the scom console, *some* hp hardware components of these 2 problem servers ARE reported/monitored using SNMP. but on both problem servers, the NIC, ILO, and Storage objects do not appear. see screenshot.
Stuart Cain
Frequent Advisor

Re: SNMP not feeding SCOM or SMH

You also need to set a community string in the SNMP service for the Insight Agents to properly forward events to Ops Mgr.

Gray icons means thre is no connectivity between the server and the Ops Mgr Agent. Can you check the Discovered Inventory view under Monitoring to see if the Server Icon is gray. If so check the Ops Mgr Agent event log to see if there is a connectivity issue
curtmcgirt
Advisor

Re: SNMP not feeding SCOM or SMH

Stuart,
sorry for the confusion. the grey icons are an unrelated issue. one of my physical boxes with this issue is a cluster host. the grey icons are all resources on that host. the screenshot was just to illustrate the *missing* NIC, ILO, and Storage HP state (from the servers with GREEN checks in the other columns)
Stuart Cain
Frequent Advisor

Re: SNMP not feeding SCOM or SMH

I read the complete thread again.
What OS is running on the servers? Note the SCOM Server MP does not support Windows 2000 Servers and PSP 8.3 does not support this OS. Formal SCOM MP Support for PSP 8.3 will not be avail until the next MP release which should be released the first part of 2010.
Note - if you are seeing the same problem with both SMH and the SCOM MP not reflecting proper state, the issue is not within the SCOM MP. You may need to do further diagnosis on the servers.
curtmcgirt
Advisor

Re: SNMP not feeding SCOM or SMH

when i opened this thread, there were 2 2008 servers with the issue. i rebooted a 2003 server this weekend and it has the same issue.
curtmcgirt
Advisor

Re: SNMP not feeding SCOM or SMH

i should say that prior to installing psp 8.3 to all my 2003 and 2008 servers, i had *a lot* of missing HP info in SCOM. since i installed it only these two 2008 servers and now one 2003 server are having the issue.
Stuart Cain
Frequent Advisor

Re: SNMP not feeding SCOM or SMH

I would suggest at this point review the attached document and if you are still seeing issues you try placing another request through the email support adr in the doc.