Network Management / (OpenView-NNM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

HP NNMi - BSM HPOM Integration Selection


HP NNMi - BSM HPOM Integration Selection

Dear Experts,


We have NNMi and BSM integration, so far everything worked fine, but the event integration suddenly stopped working.

 I don't have events in BSM OMi console and I dont have traffic on udp port 5162.


As far as I can tell there is nothing wrong in the configuration:

netstat -tulpn | grep 5162
udp        0      0      *                               539/opctrapi   


 ovc -status
coda        OV Performance Core                 COREXT       (31597)  Running
ombacksync  OM Back Sync                        AGENT,IA     (31253)  Running
opcacta     OVO Action Agent                    AGENT,EA     (31603)  Running
opcmsga     OVO Message Agent                   AGENT,EA     (31261)  Running
opcmsgi     OVO Message Interceptor             AGENT,EA     (31250)  Running
opctrapi    OVO SNMP Trap Interceptor           AGENT,EA     (539)    Running
ovbbccb     OV Communication Broker             CORE         (8323)   Running
ovcd        OV Control                          CORE         (8312)   Running
ovconfd     OV Config and Deploy                COREXT       (31195)  Running
ovtomcatB   OV Tomcat(B) Servlet Container      WEB,SERVER   (31560)  Running


I restarted the nnmi ovc, it didn't work, restarted nnm server, it didn't work, and finaly I restarted the hole system, no change. Can anyone give me some advice, what could be the problem?




Esteemed Contributor

Re: HP NNMi - BSM HPOM Integration Selection


I assume that you have checked the following:

OM Agent / Northbound settings in NNMi
OM Agent/BSMC settings (ovconfget)
SNMP Trap policy is activated in BSMC

If this seems to be ok I would try to trace northbound interface and opctrapi. BTW: you can "inject" management events in NNMi by using the JMX console (serach for inject).

HTH and kind regards


Re: HP NNMi - BSM HPOM Integration Selection

From:  ovconfget -ovrg eeagt

I am not sure about that:



Port is 5162 SNMP_TRAP_PORT=5162


Re: HP NNMi - BSM HPOM Integration Selection

The policy is activated. When  I invoke events using jmx console, the events are not coming into NNMi console or in the BSM OMi console( I am not sure what should happend with these events)

I also did  nnmsnmpnotify.ovpl -v2c -c  THE_COMMUNITY_FOR_THAT_NODE -d -a Source_NODE NNM_server_IP
Transmitted 106 bytes to localhost.localdomain ( port 162

Esteemed Contributor

Re: HP NNMi - BSM HPOM Integration Selection

If you issue for example the NodeDown incident from the NNMi JMX console you should see the incident in "All Incidents" (I assume that dampening is not active for Node Down). AFAIR you must use the node name (not the FQDN or IP).

Following the documentation NO_TRAPD is correct, but I have seen new OM agent versions (11.1x), where NETSNMP is needed.

Any Errors in nnm.log?

HTH and kind regards


Re: HP NNMi - BSM HPOM Integration Selection

Hello again :)


Yes, when I invoke incident with the right trap oid, I receive it in NNM All Incidents, but I don't get it in BSM OMi.

Probably the problem is not in the configuration, because the system worked fine for 2 years. But we had a power outage which affected the machine and I suspect that something went wrong when I started it. Unfortunately I had no idea what could it be.

As I said when I issue tcpdump on port 5162 I don't have any traffic, which suggest that I don't forward incidents to  the Integration Adaptor.

I don't  have errors in System.txt.


Best Regards,


Re: HP NNMi - BSM HPOM Integration Selection

Dear all,


I think we searched in the wrong place. I look through my bsmgw logs and I found that  opr-gateway.log is full of  [Thread-11571] ERROR SoapArgMsgList.endElement(104) - Sending events failure!

I did dbValidator.bat and it return failed:

### Index validation report ###
Index check failed. Following issues found:
- Missing index: indexOverCompT in table: bsm910_event.dbo.HISTORY_LINE in colum
n: COMPONENT_TYPE. This column already has an index with different name!


Has anyone faced similar problems? I read that I have to use checkindices.bat tool, but I am not sure of the outcome.