Network Management / (OpenView-NNM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Node is reported with wrong IP

Occasional Contributor

Node is reported with wrong IP

This is an odd one and for the life of me, I don't know how to solve it.


We have a linux machine (redhat) that has 5 interfaces:



eth2 =




bond0 (has eth0 and eth1) =

bond1 (has eth4 and eth5) =


When I add a node with HPOV NNM v7.50, I use as an IP address. It then adds the node, but later on refers to it as ''. When alarms are received, I can see that HPOV runs a whole bunch of GETNEXT requests to poll the device. However, if I right click on the node and select 'alarms' I get nothing besides:

system name changed (was and the source is


If I change the filter (and add, then the alarms are shown in the tab. But I think HPOV disregards any alarm sent from that device. I tried to change the Preferred SNMP address, to no avail.


The agent is net-snmp 5.3.


Can you please help? I'm baffled. If I send a trap from the agent on a different app, the trap is received correctly and looks perfectly fine (coming from Thanks!

Honored Contributor

Re: Node is reported with wrong IP

[ Edited ]



Yes NNM 7.5x can be rather awkward in this respect. In your case it chooses the lowest IP address as preferred SNMP management address. A netmon lrf option (-k adjustNodeSnmpAddr=false) was added in NNM 7.53 that should stop netmon from switching preferred management addresses.


But you can also try the following: 

  • Temporarily unmanage all the interfaces for the node except the interface that is to be set as the SNMP Address.
  • Issue a demand poll for the node.
  • Check the object properties of the node for SNMP address.
  • Re-manage the rest of the node's interfaces.





Occasional Contributor

Re: Node is reported with wrong IP

Thanks a lot! How do you issue a repoll? Thanks.

Honored Contributor

Re: Node is reported with wrong IP



CLI command nmdemandpoll for netmon discovery poll. Regards,