Network Management / (OpenView-NNM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

Trying to block traps

Regular Advisor

Trying to block traps

Trying to block Symbol traps using the trapFilter.conf file.  I tried each of the follwing entries:

# 8 Jan 2014 Symbol Wireless Traps (.1.3.6.1.4.1.388.50.0) <*, .1.3.6.1.6.3.1.1.5.1.3.6.1.4.1.388.50.0.*>
<*, .1.3.6.1.4.1.388.50.0.*>
<*, .1.3.6.1.4.1.388.50.0.11.0.6>

Saved the file and the ran /opt/OV/bin/nnmtrapconfig.ovpl -readFilter

When I run /opt/OV/bin/nnmtrapdump.ovpl -trapid .1.3.6.1.4.1.388.50.0.11.0.6 I still see the traps. Also the coun still rises when I look at [Tools][Total Traps Received by SNMP OID

Am I missing something?

Humbly,




 

 

 

4 REPLIES
Trusted Contributor

Re: Trying to block traps

Hi,

I think you are referring incorrect file,i don't remember the correct file name now.Please search it in the nnm guide.

Regards,
hp4u
Regular Advisor [Founder]

Re: Trying to block traps

Hi,

 

      Try the same process in nnmtrapd.conf file present in the same location in NNMi server.. and let us know if you getting traps...

 

 

--
-Vishnu.
HPE Expert

Re: Trying to block traps

Hello,

 

you can try to modify also the first part of the line:

<*.*.*.*, .1.3.6.1.4.1.388.50.0.*> instead of <*, .1.3.6.1.4.1.388.50.0.*>

You can also be more concrete if posible inserting the IP addresses of the sources.

 

You can check the OIDs bloqued using the following command:

#nnmtrapconfig.ovpl –dumpBlockList

And also checking the following file:

nnmtrapd.conf

 

Once you modified it, you can use nnmtrapconfig.ovpl –stop/start with option –readFilter to force to read the changes made.

 

 

You can check what's happening with the traps once they arrive to NNMi server by enabling the following trace:

  • #nnmsetlogginglevel.ovpl com.hp.ov.nms.events FINEST
  • #nnmsetlogginglevel.ovpl com.hp.ov.nms.trapd FINEST
  • #nnmtrapdump.ovpl –last 5 –t when the traps arrive.
  • Confirm that they are in the console.

Once you complete the tests, set the tracing levels back to CONFIG:

  • #nnmsetlogginglevel.ovpl com.hp.ov.nms.events CONFIG
  • #nnmsetlogginglevel.ovpl com.hp.ov.nms.trapd CONFIG

 

 

Hope it helps

 

BEst Regards

Honored Contributor

Re: Trying to block traps

Oscar is correct, your wildcard supposition needs to cover all octets  for IPv4, the  * alone isnt proper unless you have IPv6  licenced and enabled. Its in the upper portion of the configuration file.

 

# Both IP Addresses and Event Oids can be specified using wild card "*"
# or range using "-".  The IP Address wildcard "*.*.*.*" indicates all
# IPv4 addresses, while "*" indicates all IP addresses in both IPv4 and
# IPv6 networks (when IPv6 support is licensed and enabled).

 

 

 

Have a nice day :)

Andy Kemp,  CISSP