Network Management / (OpenView-NNM) Practitioners Forum
Showing results for 
Search instead for 
Do you mean 

new X server causing some issues

Super Advisor

new X server causing some issues

Hello

I have changed my exceed server to win-32. Now some things that were working with exceed do not work anymore. Examples:
- when I try to access the Report Configuration interface I get the message:
interpreter "/bin/sh" not found
sh: /opt/mozilla/mozilla: not found

-when I try to use the opcsv command I get smthg like:
/usr/lib/dld.sl: Can't find path for shared library: libclntsh.sl.9.0
/usr/lib/dld.sl: No such file or directory
/opt/OV/bin/OpC/opcsv[860]: 18288 Abort(coredump)
/usr/lib/dld.sl: Can't find path for shared library: libclntsh.sl.9.0
/opt/OV/bin/OpC/opcsv[23]: /bin/grep: not found.
OV Control Core components status:
----------------------------------
/opt/OV/bin/OpC/opcsv[11]: /bin/awk: not found.
(Ive checked and the /usr/lib/dld.sl file actually exists)

(On the other hand, with Win-32 I can display some graphs, even if they do not always seem realistic) whereas with exceed I got an error about the fonts (I had posted about it but did not get much support))

Thanks to all those who will try helping. Take care guys
7 REPLIES
Esteemed Contributor [Founder]

Re: new X server causing some issues

Some X windows apps work better than others. I was using X Manager and it was terrible, I'm using Refelection X version 14.0 now and it works great.
Super Advisor

Re: new X server causing some issues

Thanx for your answer Joe. I guess I should change of X server instead of trying to troubleshoot the one I am using...
Esteemed Contributor [Founder]

Re: new X server causing some issues

I mean thats not alway the right way to go about it but I was troubling shooting X manager so much that it was just stupid to keep using something that was giving me such a hardtime.
Esteemed Contributor [Founder]

Re: new X server causing some issues

Have a look at Xming also. I have Xming doing all what i can do with Exceed. But XMing is a freeware. Not sure of the support.

HTH
Pradeep
Super Advisor

Re: new X server causing some issues

Thanx for your answers folks. I have installed XMing on XP but got a Could not find per display information whereas the DISPLAY env variable was set to the right value. I had not uninstalled Exceed before running XMing. Is it possible the error comes from a conflict between the X servers? Or am I missing smthg?
Esteemed Contributor [Founder]

Re: new X server causing some issues

Did you configured XLaunch?
Highlighted
Super Advisor

Re: new X server causing some issues

Yes I had. Anyway I am using Win-32 not XMing right now. Another issue I am facing since I changed from Exceed is when trying to start the Oracle db I get the following error:
# ./ovoracle start
/usr/lib/pa20_64/dld.sl: Unable to find library 'libclntsh.sl.9.0'.
./ovoracle[1401]: 8786 Killed
ERROR: Could not start Oracle Net listener.
./ovoracle[30]: 8797 Killed
WARNING: Cannot determine, if database is running.
Starting Oracle database ...
./ovoracle[30]: 8814 Killed
ERROR: Error occurred calling sqlplus.
ERROR: Cannot start Oracle database.
Output of sqlplus:
---------------------------------------------------------------------
/usr/lib/pa20_64/dld.sl: Unable to find library 'libwtc9.sl'.
---------------------------------------------------------------------
ERROR: Problems with starting Oracle Database or none configured.

I do not know if it can be related to the X sv in some way but before, starting/stopping the db was none of a problem. As a consequence of not being able to start the Oracle db, ovoacomm (and opc) cannot be started.

Has anyone already faced such a situation?

Thanks folks