Network Simulator
cancel
Showing results for 
Search instead for 
Did you mean: 

Error when running the simulator

toto174
Occasional Contributor

Error when running the simulator

Hi,

 

I'm with GNU/Linux testing (jessie).

Kernel : 3.16-2-amd64

virtualbox 4.3.18-dfsg-1 amd64

HNS_7.1.50_x86_64.deb

 

I installed successful Virtualbox, HNS.

I run HNS and give a try with this config :

 

 

#device 1
device_id = 1
#device type is chassis
device_model = SIM1200
#host ip option 
#host_ip = 192.168.100.1
#board slot type and aux_port memory_size
board = SIM1201 : aux_port 51234
#device 2
device_id = 2
#device tyep is box
device_model = SIM1200
#board slot type and aux_port memory_size
board = SIM1201 : aux_port 51235
#connect two interface
device 1 : interface 2 <---> device 2 : interface 2

 

Then, i start the simulator but i got this error :

Failed to refresh comware version

 

Also, i gave a try to run it with sudo but it said that it can not to display on "10.0" to the X server.

X11 connection rejected because of wrong authentication.
HP Network Simulator: cannot connect to X server localhost:10.0

 

Althought i can display the "xclock" command from the terminal.

echo $DISPLAY said me that i'm ok.

I tried :

export DISPLAY="127.0.0.1:10.0"

 But nothing.

 

So, please, do you have some feedback from installing and running on Linux ?

 

Thank you in advance for your return.

 

 

1 REPLY
Jay_Flora
Frequent Advisor

Re: Error when running the simulator

Hi toto174,

 

HNS is supported only on Windows and Ubuntu as of now. I ran your script with the same virtual box image on Ubuntu 14.04 and it ran perfectly fine after I removed the ": aux_port 51234" part from line 8 and 14.

 

I did not get any errors you've mentioned. It maybe because I used Ubuntu and you're using some other unsupported version of Linux.

 

Do you have Ubuntu with the same Virtual Box version?

 

Regards,

Jay