cancel
Showing results for 
Search instead for 
Did you mean: 

Automount Problem.

suvy12
Frequent Advisor

Automount Problem.

I ma not bale to automount in a HP-UX 11iv3 server.

 

Below is the scenario

 

cat /etc/auto.direct
## Configured using SAM by root on Sun Aug 19 05:58:04 2012
## Configured using SAM by root on Tue Jun 18 22:37:07 2013

/sapmnt/PRD     -proto=udp      SAP-APP1:/export/sapmnt/PRD

 

After that i had restarted the autofs Service.

#/sbin/init.d/autofs start

 

Also reread the mount point

#automount -f /etc/autodirect -v

 

 cat /etc/auto_master
## Configured using SAM by root on Sun Aug 19 04:09:49 2012
## Configured using SAM by root on Sun Aug 19 04:09:38 2012
/- /etc/auto.direct

 

Sill while doing bdf not getting the desired output.

 

 #bdf /sapmnt/PRD
Filesystem          kbytes    used   avail %used Mounted on
/etc/auto.direct         0       0       0    0% /sapmnt/PRD

 

While on Other Server SAP-APP1

 

/dev/vg_sapapp1/sapmntprd
                   26214400 12674907 12851647   50% /export/sapmnt/PRD

# showmount -a
SAP-APP1:/export/sapmnt/PRD

 

Can someone please let me the step which i have missed or about the solution.

 

 

 

P.S. This thread has been moved from HP-UX >System Administrationto HP-UX > networking. -HP forum moderator

1 REPLY
Dave Olker
HPE Pro

Re: Automount Problem.

 


suvy12 wrote:

cat /etc/auto.direct

## Configured using SAM by root on Sun Aug 19 05:58:04 2012
## Configured using SAM by root on Tue Jun 18 22:37:07 2013

/sapmnt/PRD     -proto=udp      SAP-APP1:/export/sapmnt/PRD

 

After that i had restarted the autofs Service.

#/sbin/init.d/autofs start

 

Also reread the mount point

#automount -f /etc/autodirect -v

 

 

Did you mis-type this?  Did you really do "/etc/autodirect" or "/etc/auto.direct"?

 

Setting autofs aside for the moment, are you able to manually mount this filesystem from your NFS client?  Does the following work:

 

# mkdir /test_SAP

# mount -o proto=udp SAP-APP1:/export/sapmnt/PRD /test_SAP

 

If this command does not give the desired results then your problem likely has nothing to do with AutoFS and has more to do with general NFS configuration.

 

Regards,

 

Dave