Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Showing results for 
Search instead for 
Did you mean: 

CIFS Server: cannot get one log for each connection.


CIFS Server: cannot get one log for each connection.



I have upgraded from HP-UX 11.23 Cifs Server A.02.03.01 to A.03.02.02 and I am unable to get one samba log for each connection.

Before upgrading, this line in smb.conf worked:


log file = /var/opt/samba/<netbios_name>/logs/log.%m


But now it doesn't have any effect.  Any help, please?


Best Regards,

Patrick Wallek
Honored Contributor

Re: CIFS Server: cannot get one log for each connection.

I've not workred with Samba / CIFS that much, but  the %m appended to the log file name should give you a unique log file for each user.  Isn't the <netbios_name> portion redundant?


Also, there is this warning in the man page for smb.conf for the %m option:


      %m   the NetBIOS name of the client machine (very useful).

           This parameter is not available when Samba listens on port 445,
           as clients no longer send this information. If you use this macro
           in an include statement on a domain that has a Samba domain
           controller be sure to set in the [global] section smb ports =
           139. This will cause Samba to not listen on port 445 and will
           permit include functionality to function as it did with Samba



Re: CIFS Server: cannot get one log for each connection.



Thank you for your response. I have tried to get one log for each connection in several ways:


- without the netbios portion (/var/opt/samba/log.%m)

- listening only on port 139. In fact, in a system with HP CIFS Server A.02.03.01 (based in Samba  3.0.22) it is working and it is listening on port 445

- ensuring there are no directories starting by log.* in "/var/opt/samba", as I've read that can cause such problems.

- I have also tried with other options, such as %M, %I, and so on,,with the same results.


Best regards,