Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot connect to server

SOLVED
Go to solution
Michael Irani
Occasional Advisor

Cannot connect to server

I have set up a workgroup using NT4 Server as the server and i used a router to connect the computers. I'm having a problem connecting to the server from either computer. One of the other computers is running XP and the other is running NT5. I connected them using TCP/IP. The workgroup name is the same on all computers, and each computer has a different name set to it. The IP addresses are set correctly, and I can ping from each computer to all of the other computers.
Any help would greatly be appreciated.
-Mike
9 REPLIES
Jon Finley
Honored Contributor

Re: Cannot connect to server

If you don't have WINS server installed on the NT Server, try configuring the W2K and XP clients to use the lmhosts file.

%WINDIR%\SYSTEM32\DRIVERS\etc

lmhosts.sam needs to be renamed to lmhosts (no ".sam" extension).


lmhosts entry:
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q314108


Jon
"Do or do not. There is no try!" - Yoda
Michael Irani
Occasional Advisor

Re: Cannot connect to server

Jon
I looked at the site and made a LMHOSTS file. I attached it to this e-mail, because I'm not sure if I followed the instructions correctly. Let me know if it looks correct.
The Workgroup name is TPG.
Michael Irani
Occasional Advisor

Re: Cannot connect to server

I tried this file, and it did not work. I may have written it incorrectly. Is there anything I can do differently. I've already tried NetBUIE, and that has not worked. I have also gotten rid of the firewall I had on one of the computers. Do you need to set any values on the NT5 to use the LMHOSTS?
Do you need to add the LMHOSTS file to the server too, or just the workstation computers.
Impress me with your knowledge.
-Mike
Dan Shears
Occasional Advisor

Re: Cannot connect to server

Did using that lmhosts file work? Can you confirm that you can ping all workstations and the server from each other machine if you ping the ip address, but not the name?
"Commual Jumbers"
Jon Finley
Honored Contributor

Re: Cannot connect to server

OK.... mis-communication.

You're using only a workgroup, not trying to connect to a domain controler.

try using the lmhosts file, but only place entries similar to what you would place in the hosts file.

i.e.

196.168.1.2 Server
196.168.1.3 W2kdesktop
196.168.1.4 Xpdesktop

The names MUST be the exact computer names as they appear on the Network identification page.

(The entries the article mentioned are great IF you are trying to connect to a Domain controler, and can't. In your case, each computer in the workgroup needs to have the lmhosts file with the other computer names in it.)


Jon
"Do or do not. There is no try!" - Yoda
Michael Irani
Occasional Advisor

Re: Cannot connect to server

To answer Dan's question: using the lmhosts file did not work, but I obviosly did not set it up right. I can ping workstations and the server from each other machine using the ip address.

Now I wanted to know if I need to place the LMHOSTS file on the server computer as well.

The LMHOSTS file reads as:
196.168.1.2 Server
196.168.1.3 Jeff-HP
196.168.1.4 Mike

Thanks again.
-Mike
Michael Irani
Occasional Advisor

Re: Cannot connect to server

I also wanted to know if you need to set anything on the two NT pc's before you can use LMHOSTS, and whether or not I need to restart the computers.
-Mike
Jon Finley
Honored Contributor
Solution

Re: Cannot connect to server

Yes, you need to place a comparable lmhosts file on each computer.

And actually, you could place the same file on each (from your previous example, IF this is the complete list of computers)

196.168.1.2 Server
196.168.1.3 Jeff-HP
196.168.1.4 Mike


Make sure that the "Enable lmhosts lookup" is checked under TCP/IP properties on the WINS tab.

I don't believe that a reboot is required.


Jon
"Do or do not. There is no try!" - Yoda
Michael Irani
Occasional Advisor

Re: Cannot connect to server

Thanks for all the help. As far as the LMHOSTS is concerned, a reboot was required.
-Mike