Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

Configure 11.31 as NTP Client

 
SOLVED
Go to solution
Gary Cooper_1
Esteemed Contributor

Configure 11.31 as NTP Client

I have a SUSE Linux machine that is set up as an NTP server. It looks to me like it is using NTPv4. I want to set up my HP-UX 11.31 box as an NTP client which uses the Linux NTP server. However when I go into 'Add NTP Server or Peer' in SMH, it only lets me select 1-3 for the NTP version.

However when I do an swlist, it shows that I have C.4.2.8.2.0 HPUX NTP version 4 installed.

What's going on here? Can I make it use NTPv4?

Many thanks,

Gary

5 REPLIES 5
Bill Hassell
Honored Contributor
Solution

Re: Configure 11.31 as NTP Client

SMH probably needs to be patched.
It is much simpler to edit the two NTP config files:

1. Replace all the comments in /etc/nto.conf with

server suse-NTP-IPaddr

2. Add the NTP server to /etc/rc.config.d/netdaemons:

export NTPDATE_SERVER="suse-NTP-IPaddr"

The NTP daemon will negotiate with the server



Bill Hassell, sysadmin
Bill Hassell
Honored Contributor

Re: Configure 11.31 as NTP Client

Followup: the default for NTP will be 4 for version 4 installs. But you can also set version 4 for outgoing packets in ntp.conf like this:

server suse-NTP-IPaddr version 4

 



Bill Hassell, sysadmin
Gary Cooper_1
Esteemed Contributor

Re: Configure 11.31 as NTP Client

Thanks for the info. I've updated ntp.conf and netdaemons.

I notice from the ntp.conf man page that the version defaults to 4, so I've omitted the version parameter.

It all seems to be workin now - my HP-UX box is synchronised with my SLES machine.

I was sort of expecting somewhere along the way a message in syslog to say that it wasn't synchronised and was going to make up the difference, but there wasn't one.

Bill Hassell
Honored Contributor

Re: Configure 11.31 as NTP Client

Normally, ntpd is fairly noisy so I keep the messages in a separate log file.
Edit /etc/rc.config.d/netdaemons and change the logging location:

export XNTPD_ARGS="-l /var/adm/ntpd.log"

Then restart ntpd like this:

# /sbin/init.d/ntpd stop
# /sbin/init.d/ntpd start

Note that this wil 'jump' sync the time rather than slowly adjust the time in fractions of a second.
You will see the restart info in the ntp.log file.
If you have databases running, it is not recommended to jump the time. Instead, place the database in read-only or backup mode, then restart ntpd. Then monitor the stats with:

# ntpq -p


Bill Hassell, sysadmin
Highlighted
Gary Cooper_1
Esteemed Contributor

Re: Configure 11.31 as NTP Client

Hi Bill,

One other thing that I noticed - a new VM that I configured NTP client on also needed 'export XNTPD=1' and the NTP daemon starting manually.

There doesn't seem to be much NTP 'chatter' in syslog at the moment, so I think I'll leave the message redirection unless things change.

Thanks for all of your help.

Gary