Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Configuring X11 forwarding with HP-UX Secure Shell

 
Super Advisor

Configuring X11 forwarding with HP-UX Secure Shell

Hi there --

I have the HP-UX Secure Shell program installed on on our 11.00 system, and I wanted to configure it to allow X11 forwarding. The purpose being to allow X-based applications to run on remote desktops.

I tried to locate the sshd_config file, but I could not find it. Does anyone know where it is located, or what other file(s) should I modify to allow the X11 forwarding? Thanks.
A Journey In The Quest Of Knowledge
3 REPLIES 3
Honored Contributor

Re: Configuring X11 forwarding with HP-UX Secure Shell

Andrew,
please see:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=194847

What errors are you getting ? Does this thread resolve them ?

Please also read:
http://forums1.itrc.hp.com/service/forums/helptips.do?#33 on how to reward any useful answers given to your questions.
Honored Contributor

Re: Configuring X11 forwarding with HP-UX Secure Shell

check /etc/ssh.. if not there, look around in /usr/local.

G'luck !
an engineer's aim in a discussion is not to persuade, but to clarify.
Honored Contributor

Re: Configuring X11 forwarding with HP-UX Secure Shell

Hi Andrew,

# vi /opt/ssh/etc/sshd_config
and make sure "X11Forwarding yes" is uncommented. If you made a change to this file, restart the daemon:
# /sbin/init.d/secsh stop
# /sbin/init.d/secsh start

On the client side, make sure you have X11 forwarding enabled. If you're using command-line ssh, this is accomplished through the '-X' option (i.e. 'ssh -X '). If you're using a terminal emulator, such as PuTTY, go to SSH->X11 in the configuration, and check "Enable X11 forwarding".

PCS