cancel
Showing results for 
Search instead for 
Did you mean: 

DNS with ServiceGuard

SOLVED
Go to solution
Shukor
Frequent Advisor

DNS with ServiceGuard

Hi there,

We have 2 NIS servers whichis clustered and our plan to configure the SMTP. Both running hpux v3 on the Superdome ia64 SD32B. As advise by hp engineer, we cannot set the DNS IP Address (200.15.14.14) because will conflict with SG. I already entered 10.1.101.188 smtp.tm.com.my on the /etc/hosts but still failed the deliver the email. Need your advice please. TQ
11 REPLIES
Michael Steele_2
Honored Contributor

Re: DNS with ServiceGuard

Hi

What are the ip's for the MC/SG nodes, default router, floating ip, network id, mail server, etc?

Question: You want to set up a DNS in a two node MC/SG? Or is it NIS? Or is it SMTP? Could you narrow it done a bit please?
Support Fatherhood - Stop Family Law
Shukor
Frequent Advisor

Re: DNS with ServiceGuard

Hi Micheal,

IP node#1: 10.1.53.36
IP node#2: 10.1.53.37
route IP: 10.1.53.251
Floating IP/vIP: 10.1.53.143
Mail Server IP: 10.1.101.188 (smtp.tm.com.my)

Answer: I want to setup sendmail (will be used by dba to database alert).

Thanks in advance..
Michael Steele_2
Honored Contributor

Re: DNS with ServiceGuard

Hi

I have no clue about what your question is. Please elaborate on this comment: "...As advise by hp engineer, we cannot set the DNS IP Address (200.15.14.14) because will conflict with SG..."

What? Pray tell? Exactly! Does the DNS have to do with the mail server?
Support Fatherhood - Stop Family Law
Shukor
Frequent Advisor

Re: DNS with ServiceGuard

Micheal,

"...As advise by hp engineer, we cannot set the DNS IP Address (200.15.14.14) because will conflict with SG..."

- in order to enable smtp, we usually assign dns (see attachment, captured on other server that smtp/sendmail working good). But, I advised to not do this on NIS server because it's clustered. so, how to make sendmail working without assign DNS like attachment?
Abhijit P.
Valued Contributor

Re: DNS with ServiceGuard

Hi ,
If your requirement is just to send the DB alerts then I think you make use of mailx with the mail server configured and forwarding those alerts with the help of that mail server.
Shukor
Frequent Advisor

Re: DNS with ServiceGuard

Hi Abhijit,

yes, i can use mailx instead but DNS is required. if not assigned, sendmail/mailx fail to deliver the mail.

TQ
Michael Steele_2
Honored Contributor
Solution

Re: DNS with ServiceGuard

I think you should go ahead with the changes that you want to make and submit any server errors as they arise.

Refer to /etc/nsswitch.conf, this is the BIND resolver where multiple nameservers exist. Note that you can have multiple nameservers, and can also order their priority.

FILES refers to /etc/hosts, and can be looked up first or last. There is also NIS, and DNS.

Also refer to the /etc/reslov.conf file and note the priority ordering here as well.

I'm still not clear on the MC/SG comment, the mail server comment or the HP Engineer's comment. But I do know that the quality of HP's support has gone down hill dramatically and you may have been told, probably have been told something inaccurate, and should escalate the call to the 2nd or 3rd level at the very least.
Support Fatherhood - Stop Family Law
Matti_Kurkela
Honored Contributor

Re: DNS with ServiceGuard

As far as I know, using DNS for hostname resolution does not "conflict" with Serviceguard in any way.

If the HP engineer insists on it, please ask him/her to identify a written document (e.g. a link to document and a PDF page number) where this restriction is documented.
I think the engineer won't find such a document, and might learn something new trying :-)

We have many Serviceguard clusters, all using DNS successfully.

There are some things you should do for maximum reliability, though:

- you should have the IP addresses and names (in both fully-qualified and short forms) of all the cluster members listed in the /etc/hosts files on each cluster node

- in /etc/nsswitch.conf, you should have both "hosts" and "ipnodes" configured to look up first "files", then any other sources you want (e.g. "dns" and maybe "nis", in whichever order you need).

As you should know, any Unix system should be configured so that it always can resolve _its own hostname_ quickly and successfully, even if external name resolution services (e.g. DNS and NIS) are not available. Otherwise some very basic things can slow down if the system has network connectivity problems. This can make it harder/slower to find and fix the actual problem, so you don't want that.

In a cluster, this rule should usually be extended to other cluster nodes too: each node should be able to resolve the names of itself and any other node in the same cluster. Adding the package IP addresses and their names to /etc/hosts is useful too.

If your node or package IP addresses ever change, you must already update the configurations on each cluster node: updating the /etc/hosts at the same time requires very little extra effort.

MK
MK
Horia Chirculescu
Honored Contributor

Re: DNS with ServiceGuard

Hello Shukor,

You can enable relaying of the messages to 10.1.101.188 (edit sendmail.cf and add the line:
DS[10.1.101.188]
)

Do not forget about [] - like this you would skip some MX lookups.


>As advise by hp engineer, we cannot set the DNS IP Address (200.15.14.14) because will conflict with SG.

Why is that? What is your /etc/resolv.conf look like? You must set your DNS here, (edit that file and add this line):

nameserver 200.15.14.14

Check that you do not have any firewall between your server and the DNS:

telnet 200.15.14.14 53

If you get a connection, the setup would work. If not, you must check the firewall settings for your network.

Horia.
Best regards from Romania,
Horia.
Shukor
Frequent Advisor

Re: DNS with ServiceGuard

Hi Micheal, Matti & Horia,

Thanks for the input but I need to check and verify with the HP Engineer/ Support first before touch the server. Kindly wait for the output and I will assign the points soon. :D
Shukor
Frequent Advisor

Re: DNS with ServiceGuard

Hi Micheal, Matti & Horia,

As promised, points assigned as the problem has been solved as follow.

1. Copied /etc/nsswitch.conf file from healthy smtp server into this server.

2. Used the same smtp gateway (smtp.tm.com.my) to sendmail.cf and /etc/hosts.

Solved and :) TQ to all of you!