Dead gateway detection messages in syslog

Go to solution
Regular Advisor

Dead gateway detection messages in syslog



We lost nw connectivity to a vPAR yesterday afternoon, and at the same time these messages started to appear in the syslog.


Feb 19 04:34:15 MYHOST vmunix: Dead gateway detection can't ping the last remaining default gateway at 0xac1402c8 .See ndd -h ip_ire_gw_probe for more info


The hex address is the gateway configured.


The network team have checked everything they can, and find no faults.  The lights are flashing on the NIC.  The server is up as I can connect via the console.


Any ideas?


Do I need to set the ip_ire_gw_probe to '0', as I don't think this will make a difference, but I could be wrong.





Regular Advisor

Re: Dead gateway detection messages in syslog

Just to add, upon pinging the broadcast address, I only get replies from the NIC address.

The gateway is not pinging.

Patrick Wallek
Honored Contributor

Re: Dead gateway detection messages in syslog

I would turn off dead gateway detection on all servers.  I find that it doesn't serve any useful purpose the majority of the time.  If dead gateway detection determinues that the router is down (not pinging) then it will disable that route.  If that is your only route to the outside world, you are hosed.


If your router really is down, then I suspect you will know about it pretty quick without the HP-UX server disabling your gateway.

Regular Advisor

Re: Dead gateway detection messages in syslog

Thanks Patrick.


It was something on the Network end of things.

Bill Hassell
Honored Contributor

Re: Dead gateway detection messages in syslog

This is an old default setting that should never have existed. The network code regularly pings routers to see if they are alive (even though ping is a primitive and useless test). When the router fails to respond, the network code assumes that the router is dead and stops using that route (an even more useless action). It is not unusual for network security to disable ICMP response (ie, ping) but with this setting in HP-UX, all routed traffic is halted because of a missed ping.


Yes, you need to set the dead gateway detect to off on *every* HP-UX server you have.

To make the change permanent, edit the nddconf file in /etc/rc.config.d and add this:




The above assumes that there are no [0] entries already.

If there are, use the next available array reference such as [1] or [2].


Then run: ndd -c

which reads the file and performs the settings.

This sets the value to 0 and validates that the file is of the proper format.


(Did I mention that *every* HP-UX server needs this fix?)


Bill Hassell, sysadmin
Honored Contributor

Re: Dead gateway detection messages in syslog



Our colleague in the forum Bill Hassell is right. This can be a dangerous

problem if ignored.


As number of customers disable ICMP on internal networks (I worked with

many of those), it is becoming important to set it up properly when servers

are commissioned.


Because of that, I leared to test it when doing so-called Operations Acceptance Testing

for servers before they go into production:


Checking Deat Gateway Detect is a compulsory test for me.




VK2COT Dusan Baljevic

VK2COT - Dusan Baljevic