Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with nfs server being disabled - HPUX 11.23

SOLVED
Go to solution
Mark Parsons
Valued Contributor

Issue with nfs server being disabled - HPUX 11.23

Hi - here's hoping someone can help.

 

I am having trouble with nfs. It seems to start up okay but almost immediately stops. Here are the startups:

# ./nfs.core start
    starting NFS CORE networking

    starting up the rpcbind
        /usr/sbin/rpcbind
# ./nfs.client start
    starting NFS CLIENT networking

    starting up the rpcbind
        rpcbind already started, using pid: 5172
    starting up the BIO daemons
        /usr/sbin/biod 16
    Reading in /etc/exports
    starting up the Status Monitor daemon
        /usr/sbin/rpc.statd
    starting up the Lock Manager daemon
        /usr/sbin/rpc.lockd
    Starting up the AutoFS daemon
        /usr/sbin/automountd
        Running the AutoFS command interface
        /usr/sbin/automount
    mounting remote NFS file systems ...
    mounting CacheFS file systems ...

# ./nfs.server start
    starting NFS SERVER networking

    starting up the rpcbind daemon
        rpcbind already started, using pid: 5172
    Reading in /etc/exports
    starting up the mount daemon
        /usr/sbin/rpc.mountd 1
    starting up the NFS daemons
        /usr/sbin/nfsd 16
    starting up the Status Monitor daemon
        rpc.statd already started, using pid: 5210
    starting up the Lock Manager daemon
        rpc.lockd already started, using pid: 5216

 

Here is a copy of nfsconf:

 

#**********************  NFSCONF  ******************************

# NFS configuration.  See nfsd(1m), mount(1m), pcnfsd(1m)
#
# @(#) nfsconf $Date: 2004/08/05 12:58:31 $Revision: i380/4 PATCH_11.23 (PHKL_31
500)
#
# NFS_CLIENT:   1 if this node is an NFS client, 0 if not
# NFS_SERVER:   1 if this node is an NFS server, 0 if not
#               Note: it is possible for one host to be a client, a server,
#               both or neither!  This system is an NFS client if you will
#               be NFS mounting remote file systems; this system is a server
#               if you will be exporting file systems to remote hosts.
#               See Also:  nfsd(1M), mount(1M).
# NUM_NFSD:     Number of NFS deamons (nfsd) to start on an NFS server.  Sixteen
#               has been chosen as default.
# NUM_NFSIOD:   Number of NFS BIO daemons (biod) to start on an NFS client.
#               Sixteen has been chosen as default.
# PCNFS_SERVER: 1 if this node is a server for PC-NFS requests.  This
#               variable controls the startup of the pcnfsd(1M) server.
#               See Also:  pcnfsd(1M).
#
NFS_CLIENT=1

NFS_SERVER=1
NUM_NFSD=16
NUM_NFSIOD=16
PCNFS_SERVER=0
# export feature does not work in this file since files are being
# sourced into another file rc.config and this file is being sourced
# into the startup scripts.

#
# DAEMON OPTIONS
#
# LOCKD_OPTIONS:   options to be passed to rpc.lockd  when it is started.
# STATD_OPTIONS:   options to be passed to rpc.statd  when it is started.
# MOUNTD_OPTIONS:  options to be passed to rpc.mountd when it is started.
#
LOCKD_OPTIONS=""
STATD_OPTIONS=""
MOUNTD_OPTIONS=1
#
# rpc.mountd configuration.  See mountd(1m)
#
# START_MOUNTD: 1 if rpc.mountd should be started by a system startup script.
#               0 if /etc/inetd.conf has an entry for mountd.

#               0 if /etc/inetd.conf has an entry for mountd.
#       Note: rpc.mountd should be started from a system startup script,
#       however, it can be started from either nfs.server or inetd, and
#       MUST only be configured in one place.
#
START_MOUNTD=1
#
# AutoFS configuration.  See automount(1m)
#
# In order to invoke the AUTOFS set the AUTOFS variable to 1.
#
# The 'nfs.client start' script will also use these variables
# to determine whether to start AutoFS or not during the boot
# sequence.
# AUTOFS = 0 - do not start AutoFS
#          1 - start AutoFS.
# AUTOMOUNT_OPTIONS=  - options to the AutoFS automount command
# AUTOMOUNTD_OPTIONS= - options to the AutoFS automountd daemon
#
AUTO_MASTER="/etc/auto_master"
AUTOFS=1
AUTOMOUNT_OPTIONS=""
AUTOMOUNTD_OPTIONS=""

 

I also enclose a few screenshots from SAM. The first shot shows NFS disabled - then I enable it successfully but then if I go out of this part of SAM and then go back in again it has been disabled.

 

Many thanks in advance!

 

 

P.S. This thread has been moved from HP-UX > System Administration to HP-UX > networking. - Hp Forum moderator

 

5 REPLIES
Dave Olker
HPE Pro

Re: Issue with nfs server being disabled - HPUX 11.23

Regardless of what SAM reports, are you saying the NFS daemons are dying on their own?  What do commands like "showmount -e", "rpcinfo" and "ps -ef | grep nfs"?

 

Dave

Mark Parsons
Valued Contributor

Re: Issue with nfs server being disabled - HPUX 11.23

Thanks Dave. Commands run as follows:

 

# showmount -e
export list for drbk1:
/var/opt/omni (everyone)
/etc/opt/omni (everyone)

 

# rpcinfo
   program version netid     address             service    owner
    100000    4    ticots    drbk1.rpc           rpcbind    superuser
    100000    3    ticots    drbk1.rpc           rpcbind    superuser
    100000    4    ticotsord drbk1.rpc           rpcbind    superuser
    100000    3    ticotsord drbk1.rpc           rpcbind    superuser
    100000    4    ticlts    drbk1.rpc           rpcbind    superuser
    100000    3    ticlts    drbk1.rpc           rpcbind    superuser
    100000    4    tcp       0.0.0.0.0.111       rpcbind    superuser
    100000    3    tcp       0.0.0.0.0.111       rpcbind    superuser
    100000    2    tcp       0.0.0.0.0.111       rpcbind    superuser
    100000    4    udp       0.0.0.0.0.111       rpcbind    superuser
    100000    3    udp       0.0.0.0.0.111       rpcbind    superuser
    100000    2    udp       0.0.0.0.0.111       rpcbind    superuser
    100024    1    tcp       0.0.0.0.213.202     status     superuser
    100024    1    udp       0.0.0.0.226.117     status     superuser
    100021    1    tcp       0.0.0.0.213.203     nlockmgr   superuser
    100021    1    udp       0.0.0.0.226.118     nlockmgr   superuser
    100021    3    tcp       0.0.0.0.213.204     nlockmgr   superuser
    100021    3    udp       0.0.0.0.226.119     nlockmgr   superuser
    100021    4    tcp       0.0.0.0.213.205     nlockmgr   superuser
    100021    4    udp       0.0.0.0.226.120     nlockmgr   superuser
    100020    1    udp       0.0.0.0.15.205      llockmgr   superuser
    100020    1    tcp       0.0.0.0.15.205      llockmgr   superuser

100021    2    tcp       0.0.0.0.213.206     nlockmgr   superuser
    100099    3    ticotsord drbk1.autofs        automountd superuser
    100003    2    udp       0.0.0.0.8.1         nfs        superuser
    100003    3    udp       0.0.0.0.8.1         nfs        superuser
    100005    1    udp       0.0.0.0.226.127     mountd     superuser
    100005    3    udp       0.0.0.0.226.127     mountd     superuser
    100005    1    tcp       0.0.0.0.213.208     mountd     superuser
    100005    3    tcp       0.0.0.0.213.208     mountd     superuser

 

# ps -ef | grep nfs
    root    10     0  0  Jan 22  ?         2:33 nfsktcpd
    root  8510  8362  0 10:51:46 pts/ta    0:00 grep nfs

 

(There should be nfsd running)

Bill Hassell
Honored Contributor

Re: Issue with nfs server being disabled - HPUX 11.23

Here's the relevant info from nfsconf:

 

NFS_CLIENT=1
NFS_SERVER=1
NUM_NFSD=16
NUM_NFSIOD=16
PCNFS_SERVER=0
LOCKD_OPTIONS=""
STATD_OPTIONS=""
MOUNTD_OPTIONS=1
START_MOUNTD=1
AUTO_MASTER="/etc/auto_master"
AUTOFS=1
AUTOMOUNT_OPTIONS=""
AUTOMOUNTD_OPTIONS=""

 This is found by using the very useful alias, noc (or NoComments):

alias noc="awk 'NF && ! /^[[:space:]]*#/'"

 This useful as a filter for all the config and data files where # is the comment character:

noc /etc/ntp.conf

cat /etc/profile | noc

 

Other places to check for nfs problems:

 

dmesg

/var/adm/syslog/syslog.log

 

 

 



Bill Hassell, sysadmin
Patrick Wallek
Honored Contributor

Re: Issue with nfs server being disabled - HPUX 11.23

It appears that your NFS daemons are running.  Have you tried mounting anything via NFS?  Is NFS actually working?

 

I would not trust anything that SAM tells me.  The are a couple of things that SAM is pretty good at (kernel tuning, for instance) but a lot that it is NOT very good at.

 

 

Dave Olker
HPE Pro
Solution

Re: Issue with nfs server being disabled - HPUX 11.23

First point - the "MOUNTD_OPTIONS=1" is wrong.  1 is not an option to mountd, so please remove that.  Once you correct that, try issuing the commands:

 

atcuxvm1(/) -> /sbin/init.d/nfs.server stop
killing nfsd
killing rpc.mountd


atcuxvm1(/) -> /sbin/init.d/nfs.server start
starting NFS SERVER networking

starting up the rpcbind daemon
rpcbind already started, using pid: 1004
starting up the mount daemon
/usr/sbin/rpc.mountd
starting up the NFS daemons
/usr/sbin/nfsd 16
starting up the Status Monitor daemon
rpc.statd already started, using pid: 1068
starting up the Lock Manager daemon
rpc.lockd already started, using pid: 1074


atcuxvm1(/) -> ps -ef | grep nfs
root 10 0 0 07:39:09 ? 0:00 nfsktcpd
root 2766 1 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2768 1 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2786 2779 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2779 2768 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2777 2770 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2770 2768 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2778 2773 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2773 2768 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2775 2773 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2771 2770 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2774 2773 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2781 2768 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2780 2768 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2776 2770 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2782 2768 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2788 2779 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16
root 2787 2779 0 07:41:43 ? 0:00 /usr/sbin/nfsd 16