cancel
Showing results for 
Search instead for 
Did you mean: 

NFS Device Busy

SOLVED
Go to solution
Jonathan Caplette
Regular Advisor

NFS Device Busy

Hi guys...

I've a server that have crashed today :( and this server was exporting filesystem via NFS to another HP-UX 10.20 server... When the server crashed there was some people working on files via NFS and my server that have stayed online, give me this error:
cannot unmount /dev/... :Device Busy

I know that is because there is some processe that are using the NFS link... but the thing is I can't kill them... Does somebody have an idea on how to kill the process without rebooting my server??

Thanks
Jonathan
8 REPLIES
S.K. Chan
Honored Contributor

Re: NFS Device Busy

You can give this try .. instead of using bdf, use
# mount -v
to get the exact hostname that exported the file system (for example, say it's host.dom.com:/opt/apps) which is mounted on /test.

To see the processes using an NFS-mounted file system, specify the first argument that appears in the mount -v.

# fuser host.dom.com:/opt/apps

Then try to kill 'em ..

# fuser -k host.dom.com:/opt/apps

If it's sccesful you should be able to umount it.

# umount host.dom.com:/opt/apps

If it doesn't work, reboot is the only way.
CHRISTSHONDA CAMPBELL
Occasional Advisor
Solution

Re: NFS Device Busy

You should restart your NFS server and client to clean up any connections.

You should probably stop the NFS client.
The nfs client or server process is probably hung. You should probably restart the client and server. This should clean up device busy errors.

#/sbin/init.d/nfs.client stop
#/sbin/init.d/nfs.client start
Then try to mount the filesystem. This should clean up any connections you may have had opened.
# mount -a

If this doesn't work, then try stopping the NFS server as well.
#/sbin/init.d/nfs.server stop
#/sbin/init.d/nfs.server start

If you are still having problems, go to the NFS server and see if you have permissions to mount the directory.
on the NFS server: #exportfs
See if your client is in the output. If it is not, then add it.
# exportfs -i /tmp/nfs This will all servers to mount /tmp/nfs.

pap
Respected Contributor

Re: NFS Device Busy

Hi,
If your original nfs server is now up and running.

Please do following :

1. log on to NFS server and execute following

/sbin/init.d/nfs.server stop

2. Log on to your NFS client where you are unable to kill the processes. Execute following command

/sbin/init.d/nfs.client stop

3. Now try to kill the processes, which you want to kill.

4. got to /tmp_mnt and delete that directory.

5.once you are sucessful in killing the processes.

6.Logon to NFS server and start nfs server.
/sbin/init.d/nfs.server start

7. log on to NFS client and start nfsclient processes

/sbin/init.d/nfs.client start

I think that will solve your problem.

"Winners don't do different things , they do things differently"
pap
Respected Contributor

Re: NFS Device Busy

Have you resolved your probelm?
or still continue...??/
-pap
"Winners don't do different things , they do things differently"
Mike_316
Frequent Advisor

Re: NFS Device Busy

As this is an NFS issue, I am not sure this will work, but simply try and use fuser directly to the device to kill the processes. I.E.

fuser -cuk /dev/cxtxdx

If that doies not wqork, move up a level and try it with the mount point ...I.E...

fuser -cuk /var/opt/whatever

Good Luck!
Mike
"If we treated each person we met as if they were carrying an unspeakable burden, we might treat each other as we should" - Dale Carnegie
Jonathan Caplette
Regular Advisor

Re: NFS Device Busy

Thanks guys...

Pap's solution worked fine..

thanks again!
pap
Respected Contributor

Re: NFS Device Busy

Hi,
I am glad that you resolved your problem and my solution worked for you.

Thanks,
-Piyush.
"Winners don't do different things , they do things differently"
fredie_barron
Occasional Visitor

Re: NFS Device Busy

fuser -cu /xxx to see which device is using nfs..