cancel
Showing results for 
Search instead for 
Did you mean: 

NFS export files

 
Yaroki
Super Advisor

Re: NFS export files

 

Despite showmount -e shows:

/var (everyone)

/scc (everyone)

/tmp (everyone)

 

Its  not working... 

 

 

This is the commend I use to the mount.

#mount 8.12.4.135:/tmp /server1

 

Is it concern to the shell I'm working with?

Should I check any config file?

 

Yali

Dave Olker
HPE Pro

Re: NFS export files

Let's establish that you can get basic NFS working before we start playing with syntax. On the 11.11 NFS server use the following lines in /etc/exports:

 

/var

/tmp

/scc

 

Then issue the commands:

 

# exportfs -uav

# exportfs -av

# cat /etc/xtab

 

The xtab file shows what the kernel thinks is exported/shared for NFS clients to access.  Once you verify that all three filesystems are exported with no options, try mounting the /tmp filesystem from one of the clients.  If that doesn't work then show a cut/paste of the NFS server from the above commands and a cut/paste of the NFS client showing the failing mount command.

 

Dave

Yaroki
Super Advisor

Re: NFS export files

Please find the attached files

Dave Olker
HPE Pro

Re: NFS export files

Log into the client system and issue the command:

rpcinfo -p 8.12.4.135

Post the results.
Yaroki
Super Advisor

Re: NFS export files

Please find the attached the output file. 

Dave Olker
HPE Pro

Re: NFS export files

The output shows the nfsds are either not running on the NFS server or they are not registered with rpcbind.  Try the following commands and post the output:

 

/sbin/init,d/nfs.server stop

/sbin/init.d/nfs.server start

 

After the NFS server processes are restarted, see if the earlier rpcinfo command shows entries for the nfsds on the server.

Yaroki
Super Advisor

Re: NFS export files

Unfortunately, restarting the service didn't help.

 

What's next?

Matti_Kurkela
Honored Contributor

Re: NFS export files

If /etc/rc.config.d/nfsconf specifies that the NFS server daemons are supposed to be disabled, running the "/sbin/init.d/nfs.server" script won't do anything at all.

 

Please attach your nfsconf file.

 

Also note that the HP-UX startup scripts read /etc/rc.config.d by executing /etc/rc.config, which reads *all* the files in /etc/rc.config.d directory (excluding only a few well-known backup file suffixes). If any of the files contain variables that have the same names as the variables in the nfsconf file, *and* the filename sorts after "nfsconf" in basic US-ASCII alphanumeric sort order, then those variables will override the settings made in the nfsconf file.

 

Never leave any files like "nfsconf.old" or similar in /etc/rc.config.d. If you must keep the old version as a backup, move it to some other directory.

 

MK
Highlighted
Yaroki
Super Advisor

Re: NFS export files

Hello,

 

Sorry for the delay.

Please find the attached nfsconf file.

I do not have any backup file that was saved with .old or similar in /etc/rc.config.d.

(In order to attach the file I've changed the its suffix to .txt)

 

Thanks,

 

Yali