cancel
Showing results for 
Search instead for 
Did you mean: 

NFS problem

BuSchu
Occasional Visitor

NFS problem

When I start the script aclocal from the autoconf package, it runs normal if started from a local directory. But started from a NFS network drive, it hangs.

 

uname -a says HP-UX hp1123it B.11.23 U ia64 0388897151 unlimited-user license

 

Is it a known problem? Is there a patch available?

 

Thanks in advance!

 

Regards

Burkhard

4 REPLIES
BuSchu
Occasional Visitor

Re: NFS problem

The mounting options are rw,rsize=8192,wsize=8192,hard,intr
Patrick Wallek
Honored Contributor

Re: NFS problem

What is the script aclocal?  What do you mean by "it hangs?"

 

Does the script do anything?  Does it provide any output?  What is the script supposed to do when it runs normally?


 

>>Is it a known problem? Is there a patch available?

 

Good question. 

Dave Olker
HPE Pro

Re: NFS problem

The symptoms make it sound like a file locking issue.  Do you know if the aclocal script is attempting to lock any files in the NFS-mounted directory?  I've seen hundreds of cases where somethings "works" locally but "hangs" via NFS and most of the time it's because the application is attempting to lock a file and there is something about the NFS file locking configuration that causes the hang.  Vast majority of those cases are hostname/IP resolution problems.

 

Do you see any files when you issue this command on either the NFS client or server?

 

# ll -R /var/statmon

 

Dave

BuSchu
Occasional Visitor

Re: NFS problem

Now I think it's the same problem I had when I tried to install from a NFS drive. There are a lot of messages that you cannot use swinstall working on a NFS drive. Bit I've found no real solution for this problem. Only the work around "copy the files to a local drive".

 

It seems to be a big problem working with NFS on HP-UX. Other Unixes don't have this problem! What's wrong in HP-UX?

 

Regards

Burkhard