Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

Networking with XP Home and 2000 Pro

SOLVED
Go to solution
James Caldow
Advisor

Networking with XP Home and 2000 Pro

Hi,

I hope someone can help me with this one, because it has been causing some sleepless nights. I have a Dell desktop running Windows 2000 Professional and an HP Pavilion running XP Home. I am trying to link both computers directly using an RJ45 crossover cable. I am trying to enable file and internet sharing, with the host being the 2000 machine. Whenever I try to run the wizard on 2000, I get an error message telling me that the "routing and remote access service is unable to start". So far I have not been able to make any headway towards forming a link. Before anyone suggests getting XP to create the setup disk, the Pavilion doesn't have a floppy or CD-RW, so that is out of the question! Any suggestions as to how I should proceed would be greatly appreciated.
4 REPLIES
Ron Kinner
Honored Contributor
Solution

Re: Networking with XP Home and 2000 Pro

You don't need the wizard for an Ethernet connection. Start/Settings/Network and Dial-up Connections. Windows should have automatically created an entry which says Local Area Connection. (If you have two NICs then we are interested in the one which will go to the XP.) If you don't have one then your NIC is not installed correctly or didn't get recognized. Right click on Local Area Connection and select Properties. You should have:

Client for Microsoft Networking
File and Printer Sharing
Internet Protocol (TCP/IP)

If you don't have all three click on install and add them.

If you are asked for an IP address and mask tell it 10.1.1.1 with mask 255.255.255.0. Do not give it a gateway.

IF TCP/IP is already installed then right click on it and select properties then set the IP address and mask as above. (Do not leave it set to Obtain an IP address Automatically.) Click on Advanced and make sure it has Enable LMHosts Lookup and Enable NetBIOS over TCP/IP checked. Say OK until it lets you out of the setup.

Open Explorer and go to Winnt\System32\drivers\etc.

Copy the lmhosts.sam file then modify it say to nothing but

10.1.1.2 NameofXPbox

Save your changes then rename your copy to lmhosts

Repeat the same on the XP except give it an address of 10.1.1.2 and set its gateway to 10.1.1.1 and make the lmhosts files say:

10.1.1.1 NameofWin2Kbox

Now open a DOS window on each and type:

ipconfig

It should show you that it has the 10.1.1.x ip address with the proper mask.

Now on the XP type
ping 10.1.1.1
and you should get a reply.

On the Win2k you type
ping 10.1.1.2

You should be able to map network drives now.



Now go to:

http://www.microsoft.com/windows2000/en/professional/help/default.asp?url=/WINDOWS2000/en/professional/help/Share_conn_overvw.htm

and follow their instructions to get the internet sharing to work.

Ron



Roger Faucher
Honored Contributor

Re: Networking with XP Home and 2000 Pro

James:

On the WIN2K PC, in Control Panel, under Network & Dial-up Connections, right click on Local Area Connection, make sure you have Client for Microsoft Networks, File and Printer Sharing..., and Internet Protocol (TCP/IP) are installed. Double-click on TCP/IP and set the IP address to 192.168.2.2 and the subnet mask to 255.255.255.0. Do essential the same thing on the XP machine (except set the IP address to 192.168.2.3). Go into My Computer on each machine and right-click on the C: drive and select Sharing. Share the C: drive and give the share a name.

In System Properties, click on Network ID, and set up a non-domain network with different computer names and identical Workgroup names.

Also, create 2 identical users/passwords on both PCs.

Reboot and 'drill down' into My Network Places until you find the Workgroup and you should see an Icon for each of the 2 PCs. Opening each one should reveal that computer's C: drive contents.

I hope this works for you. Let us know.

Roger
Make a great day!

Roger
Roger Faucher
Honored Contributor

Re: Networking with XP Home and 2000 Pro

Sorry:

Ron had not replied yet when I started typing. I've gotta stop watching TV while I'm doing this!

Roger
Make a great day!

Roger
James Caldow
Advisor

Re: Networking with XP Home and 2000 Pro

Thanks Ron and Roger. Sorry I have taken so long to assign points to you, but it has taken me this long to figure things out!
Both of your solutions work perfectly, which is why I have assigned you both 10 points each. Initially I tried to get the network set up without success. I tried and tried, and on each new attempt I failed. I couldn't even ping either of the computers from the other. I knew the hardware worked because I could use Symantec's PC Anywhere to transfer files between the two. Then today, on a whim, I disabled Norton Internet Security on both machines and voila, perfect connection straight away! (At least I know that NIS is doing it's job!).
I now have NIS configured to allow communications between the computers and have it switched back on.
So my advice to anyone in the same situation is, no matter what you think you know, don't assume anything! Switch off EVERYTHING that could be causing problems for the network.
Once again, many thanks guys.