Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Not able to ping to FQDN

Rahul85
Occasional Contributor

Not able to ping to FQDN

Hi,

 

I have 1 solaris server inside that there are couple of zones.

When i am trying to ping to FQDN it is not working.

If i ping server directly by server name its going fine.

Could you please help me where i need to check.

 

Regards,

RC

 

3 REPLIES
Patrick Wallek
Honored Contributor

Re: Not able to ping to FQDN

How are you resolving host names?  Are you using DNS?  What happens if you try to do an 'nslookup' ofr the FQDN? 

Rahul85
Occasional Contributor

Re: Not able to ping to FQDN

Hi,

 

Thanks for reply. Nslookup is working fine.

It having issue when we ping FQDN.

 

Thanks,

RC

Matti_Kurkela
Honored Contributor

Re: Not able to ping to FQDN

The nslookup command can have different behavior in different unix-style OSs:

  • In HP-UX, the standard nslookup command will look up both DNS and /etc/hosts, according to the settings in /etc/nsswitch.conf.
  • In most modern Linux distributions, the nslookup command will always use DNS only. This means it may give different results than the regular applications get when resolving hostnames using a gethostbyname() system call.
  • I wonder how Solaris behaves in this regard?

If you run nslookup with FQDN and get an IP address as a result, try pinging using that IP address. If the ping is successful, the problem is that the ping command cannot resolve the FQDN: check your /etc/nsswitch.conf and /etc/resolv.conf.

 

Note that IPv6-aware programs might use a different nsswitch.conf line than the IPv4-only programs. For example, in HP-UX 11.23 and newer, the hostname lookup of IPv4 programs is controlled by the "hosts:" line in /etc/nsswitch.conf, but IPv6-supporting programs use the "ipnodes:" line instead (for both IPv4 and IPv6 lookups!). I guess that a modern Solaris system might have IPv6 support included in commands like ping too.

 

If the ping with the IP address (from the FQDN nslookup) fails, then do another nslookup with the short name and see if it reports the same IP address. If the second nslookup produces a different IP address, check the "domain" or "search" lines in /etc/resolv.conf: perhaps the default domain suffix is not the one you expect.

Also check /etc/hosts: if it includes a line with the wrong IP address + FQDN, fix it.

MK