RH Networking

 
SOLVED
Go to solution
Duffster
Valued Contributor

RH Networking

Hi,

I am running RH Linux 5.4 and I am unable to ping the gateway or any other server on its vlan despite the fact that the ethernet links are being detected by 'ethtool'.

 

The gateway is configured correctly in the routing table.

 

I have checked the ethernet settings (ifcfg-bond0/eth0/eth4) and everything appears to be correct.

I have restarted the network and the ports shutdown and restart without any errors.

I can ping my host IP so ICMP is enabled. I suspect an issue with the switch port but this is a remote server and I only have visibility via the ILO which again does not show any errors.

Also when I run a 'watch ifconfig bond0' I can see packet passing through the NIC.

I have also configured /etc/modprobe.conf – “alias bond0 bonding”

# modprobe --list | grep bonding

/lib/modules/2.6.18-164.el5PAE/kernel/drivers/net/bonding/bonding.ko

Any ideas?

R,

D

6 REPLIES 6
Naj
Valued Contributor

Re: RH Networking

Hi,

How about

#netstat -rn output?

are this server run under virtual server?

 

BR

Naj


____________________________________________
:: Really appreciate if you could assign some points.
:: Don't know how to assign point? Click the KUDOS! star!
Duffster
Valued Contributor

Re: RH Networking

Hi,

 

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 bond1
192.168.235.0   0.0.0.0         255.255.255.0   U         0 0          0 bond0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 bond1
0.0.0.0         192.168.235.1   0.0.0.0         UG        0 0          0 bond0

 

R,

D

Naj
Valued Contributor

Re: RH Networking

Hi,

Your routing table looks ok.If you running under virtual machine, it probably issue with VC which is need to be restart.

Run tcpdump to check packet go through and you may get some hints to start troubleshoot.

Thanks

BR
Naj

____________________________________________
:: Really appreciate if you could assign some points.
:: Don't know how to assign point? Click the KUDOS! star!
Duffster
Valued Contributor

Re: RH Networking

Hi,

 

My tcpdump output shows successful Tx & Rx of packets with no errors.

 

The output of "watch ifconfig bond0" also shows packets getting transmitted & recieved with no errors.

 

R,

D.

Duffster
Valued Contributor

Re: RH Networking

......still unable to ping the gateway or any other server on the vlan though???

Duffster
Valued Contributor
Solution

Re: RH Networking

As suspected this was a hardware issue at the switch level.

 

The platform was fine as was the network configuration. The main ethernet cable was dislogded; the joys of supporting a remote server.

 

R,

D.