Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

Reg dns entry for servers in LAN

coollllllllllll
Regular Advisor

Reg dns entry for servers in LAN

Hi ,

 

We have a dns server at xyz location.

We have our servers located in Y location.

When we access servers from "xyz" we dont face any issue reg password prompt taking too much of time.

 

But when we access servers from "Y" location i.e we take a remote desktop connection and from there we take hpux login of our server's, where password prompt takes 1 min minimum to come .

 

What could be the issue ??? here..

1 REPLY
Bill Hassell
Honored Contributor

Re: Reg dns entry for servers in LAN

Veyr, very common. HP-UX tries to validate the incoming IP address by resolving that address to a hostname. If you use the (poor) default setting in nsswitch.conf that looks at DNS and then the hosts file, a defective DNS system will cause a 30 second delay for every entry in in /etc/resolv.conf.  Change nsswitch.conf to use the new hosts: line and add ipnodes: (if it is not already there):

 

hosts:        files [NOTFOUND=continue UNAVAIL=continue] dns
ipnodes:      files [NOTFOUND=return UNAVAIL=return TRYAGAIN=return]


Now edit /etc/hosts and put the IP address of the remote system. Since you are using a complicated connection (remote desktop then a connection to HP-UX), find out what address HP-UX is seeing by logging in and typing the command:

 

who -muR

 

If the last entry is not an IP address, use nslookup to translate the hostname to an IP address.

 

Secondly, /etc/resolv.conf holds the IP addresses for your DNS servers. If one or more of those addresses do not point to a working DNS server, or the DNS admins did not provide IP-to-hostname records, then each entry will cause another 30 second delay. Use nslookup to verify each DNS server:

 

nslookup $(hostname) 12.34.56.78

 

where 12.34.56.78 is one of the DNS server addresses. You should get a correct response instanly.



Bill Hassell, sysadmin