Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

Remote Desktop No Longer Working

SOLVED
Go to solution
Geoff Wild
Honored Contributor

Remote Desktop No Longer Working

I was helping my wife setup her office computers a while ago and I'm having trouble with her PC and remote desktop.

It used to work, but here's what happened.

The company she was working for split in two.

The side she went to doesn't have a server - so they went from DOMAIN to WORKGROUP.

I also installed Antivirus and Personal Firewall Trend Micro™ Client Server Security for SMB on her PC.

The Firewall portion is turned off and they are using Windows Firewall instead.

BTW - they are running XP Pro SP2.

All the other PC's work with remote desktop except for my wife's.

Error message is:

"The client could not connect to the remote computer. Remote connections might not be enabled or the computer might be too busy to accept new connections. It is also possible that network problems are preventing your connection. Please try your connection again later. If the problem continues to occur, contact your administrator."

Allow users to connect remotely to this computer is set in SYSTEM -> REMOTE

In the Windows Firewall, the check box next to Don't allow exceptions is cleared and in the Exceptions list Remote Desktop is set.

In Services, Terminel Services is started.

In Group Policy, Allow logon through Terminal Services has Administrators and Remote Desktop Users

A
netstat -an | find "3389"
Reveals nothing - IE - her machine is NOT listening on port 3389.

I have disabled the firewall, I have disabled Trend, rebooted, and still it isn't listening…

As a test, I also disabled the firewall, uninstalled Trend - and still get the same error when trying to connect.

I am stumped and wasted a few hours googling...and about 6 hours at her office...Does anyone have any idea what it might be?

Thanks....Geoff
Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
8 REPLIES
KJPowers
Occasional Visitor

Re: Remote Desktop No Longer Working

Strange problem... my first thought is that maybe it's listening on a different port for some reason: http://support.microsoft.com/kb/q187623/

I'm also running XP SP2 (and my remote desktop works fine), so maybe this information will help you out a little bit.

My computer has this as the path to the executable: "C:\WINDOWS\System32\svchost -k DComLaunch"

Running 'netstat -abv' returned this for port 3389:
"TCP lazor:3389 lazor:0 LISTENING 912
C:\WINDOWS\System32\httpapi.dll
c:\windows\system32\ssdpsrv.dll
C:\WINDOWS\system32\RPCRT4.dll
[svchost.exe]"

I suppose you could run that same command (takes a few minutes to run) and look for the same information to see if it's listening on a different port. FYI: svchost runs a few services on lots of different ports; mine is also listening on epmap, ntp, 1413, 1026, 1084, 1429, 1688, 1689, 3255, 3256, 3257, 2869, & 1900.

Hope that helps a little bit. Maybe you can use a VNC solution until you figure this one out.
Jon Finley
Honored Contributor

Re: Remote Desktop No Longer Working

In a WorkGroup environment, you're using a master browser to resolve names. Try connecting to the system by using the WINS/NetBIOS name (short name) rather than by IP address or FQDN.

Jon
"Do or do not. There is no try!" - Yoda
Antoniov.
Honored Contributor

Re: Remote Desktop No Longer Working

Hi Geoff,
I guess there is a privilege trouble in that PC. When your wife's PC was in domain, all security was manager by domain policy.
Do you work as local administrator (I mean original administrator, not a copy of administrator)?
Can you see and change security property of any file in PC? Check for all files in "Document And Setting" and Windows folders.
Look at event viewer for any clues.

Antonio Vigliotti
Antonio Maria Vigliotti
Geoff Wild
Honored Contributor

Re: Remote Desktop No Longer Working

Okay - her office has moved and I built them a server.

They now have a domain again.

Yet, her computer is the only one that will NOT allow remote desktop :(

Same message as above.

Rgds...Geoff
Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
Jon Finley
Honored Contributor

Re: Remote Desktop No Longer Working

In Windows Firewall, within the Remote Desktop exception, edit the entry, and see what the scope is. It should be set to "Any".

Jon
"Do or do not. There is no try!" - Yoda
Geoff Wild
Honored Contributor

Re: Remote Desktop No Longer Working

Jon - yep - been there - done that - I even tried playing with it to restrict it to local subnet - then moved it back. I setup a w2003 server - I can remotely admin the workstation (event viewer, services, regedit, etc) - just can't remote desktop in...

Windows Firewall is running (even if I disable - still no go )....

The funny thing is, the other workstation in her office works just fine.

Oh, I can remote desktop out of the workstation (to the other workstation and to the server).

Terminal services is running....

Rgds...Geoff
Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
Jon Finley
Honored Contributor
Solution

Re: Remote Desktop No Longer Working

Did you ever confirm the port?
http://support.microsoft.com/kb/306759

Also, just in case it is due to some "random" policy, try running RSOP.MSC

Jon
"Do or do not. There is no try!" - Yoda
Geoff Wild
Honored Contributor

Re: Remote Desktop No Longer Working

Aha!

Jon had the answer - it was set to 4444!

Changed to 3389 and reboot - works like a charm.

Then my wife says to me - oh - I remember the "desktop" guy at our last place made some change to my PC so I can connect through the firewall....

Rgds...Geoff
Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.