Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

Telnet connections to HP-UX hangs randomly

Felipe Rivera
Occasional Visitor

Telnet connections to HP-UX hangs randomly

Hi there

I have a weird problem here.
When connecting to a B.11.00 A 9000/803 hp-ux using telnet after a random time the telnet session hangs completely. Even if I have several telnet sessions, all of them hang at the same time!! After hanging I'm able to open a new telnet session to the server with no problem, but the original hung sessions are still hung.

Now, if I launch an xterm within the telnet session, the xterm doesn't hang even after the telnet session has.

I've tried installing several patches with no luck (PHNE_22397, PHNE_21835, PHNE_21822). Also installed PHNE_22566 but this one gave several problems (the loopback interface couldn't be configured and the box would reboot) so I had to uninstall it.

I've also tried using a different shell, playing with stty settings, playing with network parameters, but with no luck.
Also tried different telnet clients: Linux RedHat 6.2 telnet, Windows 95/NT telnet and the same.

Also rlogin sessions hang.

I'm not an HP-UX expert, but it seemed weird to me that there were an 4136 MTU value in some entries in the routing table other than those related to the loopback interface.

If you need more info please let me know.
10 REPLIES
Printaporn_1
Esteemed Contributor

Re: Telnet connections to HP-UX hangs randomly

Hi,

Please check in /var/adm/syslog/syslog.log
if you got error "not enough pty" please increase kernel paramaeter name pty,nstrpty

thanks
enjoy any little thing in my life
Bill McNAMARA_1
Honored Contributor

Re: Telnet connections to HP-UX hangs randomly

You need to send us some output:

lanscan
ifconfig lan0
netstat -nr
ioscan -fnkClan

You might also want to make sure that the
system is not overloaded. Check the top
command to view system loads.

Also a reboot is never out of the question..
!

Later,
Bill

It works for me (tm)
Marcelo De Florio
Frequent Advisor

Re: Telnet connections to HP-UX hangs randomly

Another posibility is to use the lanadmin command to display the statistic for the network card, so if errors is appears you have a problem with the network.

MDF
Felipe Rivera
Occasional Visitor

Re: Telnet connections to HP-UX hangs randomly

Here's more info guys

1. There are no error messages in /var/adm/syslog/syslog.log

2. The load is fine (0.00 :)
3. I've rebooted it several times

# lanscan
Hardware Station Crd Hdw Net-Interface NM MAC HP-DLPI DLPI
Path Address In# State NamePPA ID Type Support Mjr#
8/16/6 0x08000955EAF4 0 UP lan0 snap0 1 ETHER Yes 119

# ifconfig lan0
lan0: flags=843
inet 192.168.1.152 netmask ffffff00 broadcast 192.168.1.255

# netstat -nr
Routing tables
Dest/Netmask Gateway Flags Refs Use Interface Pmtu
127.0.0.1 127.0.0.1 UH 0 191 lo0 4136
192.168.1.152 192.168.1.152 UH 0 90 lan0 4136
127.0.0.0 127.0.0.1 U 0 0 lo0 4136
192.168.1.0 192.168.1.152 U 2 0 lan0 1500
default 192.168.1.1 UG 0 0 lan0 1500

# ioscan -fnkClan
Class I H/W Path Driver S/W State H/W Type Description
===================================================================
lan 0 8/16/6 lan2 CLAIMED INTERFACE Built-in LAN
/dev/diag/lan0 /dev/ether0

**** lanadmin statistic output ****
PPA Number = 0
Description = lan0 Hewlett-Packard LAN Interface Hw Rev 0
Type (value) = ethernet-csmacd(6)
MTU Size = 1500
Speed = 10000000
Station Address = 0x8000955eaf4
Administration Status (value) = up(1)
Operation Status (value) = up(1)
Last Change = 100
Inbound Octets = 4772026
Inbound Unicast Packets = 10737
Inbound Non-Unicast Packets = 35401
Inbound Discards = 0
Inbound Errors = 0
Inbound Unknown Protocols = 7833
Outbound Octets = 920348
Outbound Unicast Packets = 8633
Outbound Non-Unicast Packets = 37
Outbound Discards = 0
Outbound Errors = 0
Outbound Queue Length = 0
Specific = 655367


Thanx
Bill McNAMARA_1
Honored Contributor

Re: Telnet connections to HP-UX hangs randomly

There is another user here with a similar problem, I recall hearing about problems such
as this caused by NFS. Are all users home dirs
NFS mounted. Try logging in as root.. and seeing if its the same. Someone from HP RC
could verify the suspicion quicker than me, but
its possible you need an NFS patch.

Later,
Bill
It works for me (tm)
Felipe Rivera
Occasional Visitor

Re: Telnet connections to HP-UX hangs randomly

Hi there again

Still with the problem

I have more info
- The only account i've been using is root
- There are no NFS mounted/exported directories, although all needed NFS daemons are running, to mount or export a directory.
- A coworker here told me that the problem was also present when telnetting from a Windows 95/98/NT box... (I posted this in the original message).. but I didn't actually test it myself.. so I did it yesterday, and there was no problem at all connecting using NT's telnet nor CRT on Windows 98.. so that narrows the problem to Linux.
And it's not a problem with Linux's telnet client, since the problem also happens when using a Java Telnet client running over Linux. So far I've only tried RedHat 6.2, kernels 2.2.16 and 2.2.17, and Mandrake 7.1, kernel 2.2.15 and Mandrake 7.2 kernel 2.2.18
Felipe Rivera
Occasional Visitor

Re: Telnet connections to HP-UX hangs randomly

Hi guys.. who is willing to analyze a tcpdump trace between the HP-UX server and a Linux client?
See the attachment. It's in tcpdump format. If you need a different format for the trace let me know.
192.168.1.15 is the Linux box and is the one that started the telnet session.
192.168.1.152 is the HP-UX server.
Volker Borowski
Honored Contributor

Re: Telnet connections to HP-UX hangs randomly

This appears to be the typical reverse-lookup problem from telnet.
There are a couple of notes about this when you search this forum ("telnet hangs" or so).
How does "nslookup 192_168_1_15_name" resolve form 192.168.1.152 ?
/etc/host - entry and nsswitch.conf setup on 1.152 ?

Volker
Felipe Rivera
Occasional Visitor

Re: Telnet connections to HP-UX hangs randomly

Hi Volker

Yesterday I uninstalled all the patches I had applied... and one of the side effects of doing that was that the nsswitch.conf file ended just with
hosts: files
I changed it yesterday to
hosts: dns files

And yes, resolv.conf is fine and I can resolve bot the name and the IP of the Linux box just fine.

Now, taking a look at the tcpdump trace (I'm not a TCP expert, but I want to find what's going on) it seems that for some reason the Linux box gets stucked in the same ACK number even though the HP-UX box already sent that packet and also already retransmitted it .... this happened with several Linux kernels... (2.2.15, 2.2.16, 2.2.17, 2.2.18, even 2.4.2)
Laura Garcia L
Occasional Visitor

Re: Telnet connections to HP-UX hangs randomly

SOLVED!

I've got the same problem with linux thin clients and old HP-UX server (11.11). All connections to this server throught telnet, ssh or ftp hangs after minutes after booting the client.

The problem was due to the timestamp tcp header. When this timer overflow and start again from 0, then the server comes to drop packets.

See this link:
https://www13.itrc.hp.com/service/cki/docDisplay.do?docId=ttr_na-SSB_1000519698&docLocale=en&admit=109447627+1264089301915+28353475

Deactivating timestamp kernel option client or server side just works.

In linux do:

echo 0 > /proc/sys/net/ipv4/tcp_timestamps

or at server side with ndd tunable tcp_ts_enable to 0.