Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN not accepting DHCP address

 
Heiko_7
Advisor

VLAN not accepting DHCP address

Goodmorning,

 

after creating a vlan using SMH.

 

I'm trying to configure it to use dhcp.

 

After enable DHCP again using SMH, and bringing up the interface, no ip addres is assinged.

 

 

Netconf:

   INTERFACE_NAME[2]="lan5002"
DHCP_ENABLE[2]="1"
IP_ADDRESS[2]=""
SUBNET_MASK[2]=""
BROADCAST_ADDRESS[2]=""
INTERFACE_STATE[2]=""
#DHCP_ENABLE[2]="1"
INTERFACE_MODULES[2]=""

 

 

#ifconfig lan5002

lan5002: flags=4000000000001843<UP,BROADCAST,RUNNING,MULTICAST,CKO,VLAN>
        inet 0.0.0.0 netmask 0

 

 

#dhcp-client -b lan5002 -p

 

-------------- Start Packet --------------------------
BOOTP REQUEST packet
HW addr type  HW addrlen Hops  XID      Secs     Flags
 ethernet         06     0000  46183c5f 00000000 0000
ciaddr       yiaddr      siaddr      giaddr
0.0.0.0   0.0.0.0   0.0.0.0   0.0.0.0
HW addr = 00:17:08:d1:92:3d:
server name:
"empty string"
boot file:
"empty string"
-------------- Options -------------------------------
TAG = DHCP message type : 03
TAG = DHCP Class ID : "HewlettPackard.HP-UX"
TAG = DHCP Param. Req. list : 0x01,0x10,0x29,0x1c,0x06,0x0f,0x28,0x0b,0x0c,0x03,0x21,0x2a,
TAG = DHCP Req. IP Address : 10.253.123.64
-------------- End Packet --------------------------

-------------- Start Packet --------------------------
BOOTP REPLY packet
HW addr type  HW addrlen Hops  XID      Secs     Flags
 ethernet         06     0000  46183c5f 00000000 0000
ciaddr       yiaddr      siaddr      giaddr
0.0.0.0   10.253.123.64   10.250.6.1   10.253.254.254
HW addr = 00:17:08:d1:92:3d:
server name:
"10.250.6.1"
boot file:
"BStrap\X86pc\BStrap.0"
-------------- Options -------------------------------
TAG = DHCP message type : 05
TAG = DHCP Server ID : 10.91.140.8
TAG = DHCP Address Lease : 00007080
TAG = Subnet Mask : 255.255.0.0
TAG = Domain Name Server : 10.91.140.8
TAG = Domain Name : "<domain>.nl"
-------------- End Packet --------------------------

 

 

It looks like i'm missing something here

Why isn;t the interface accepting the assinged address

 

Hope there is someone out there who can tell me what i'm missing here

 

Kind regards

 

Heiko

1 REPLY 1
Highlighted
Matti_Kurkela
Honored Contributor

Re: VLAN not accepting DHCP address

When a HP-UX system uses DHCP, the dhcpclient command is run by the auto_parms script very early in the system boot sequence. That is, before VLANs or any other advanced networking features are started up.

 

Apparently the DHCP support of HP-UX is rather minimal and intended for installation and workstation-like usage only.

 

Based on a quick browsing through the network-related /sbin/init.d scripts in HP-UX 11.31, I don't think you can successfully use DHCP with VLAN network interfaces. (I could not find anything that would call auto_parms or dhcpclient from /sbin/init.d/vlan or /sbin/init.d/net.)

MK