Networking
Showing results for 
Search instead for 
Do you mean 

W2k trying to access a ghost share

Valued Contributor

W2k trying to access a ghost share

I was experiencing with a PPTP connection with W2k's own tools. I was able to connect to the PPTP server in the company's network and was able to mount some share on Samba server to a drive letter. After using it, I disconnected the mount and disconnected the PPTP connection.


Now, when I double-click anything on the desktop, or try the Start menu, W2k tries to connect to that particular share I was using previously. The system (explorer.exe) seems to hang for about 30 seconds because the share is unaccessible (I'm in a foreign network). This connection attempt can be seen with "nbtstat -s" command, it says "Connecting \\computer\share" and the desktop waits. Even IE hangs at that time if I press the Back button meanwhile. After that 30 seconds everything is fine again, applications continue to start or whatever.

That share name is not mentioned anywhere else in the registry but in the Map Network Drive dialog's Last Recently Used list. The share is not currently mounted to any drive letter.

The computer has been booted several times, it's a few days now when I used the PPTP connection. I experienced the same issue with two different W2k workstations. No domains involved.

So, why W2k is still trying to see the share, and why is it trying it while I'm just starting some software from the desktop (or from the Start menu)? How do I stop W2k from looking for that share?
5 REPLIES
Honored Contributor

Re: W2k trying to access a ghost share

If you created ANY shortcuts from the mapped drive/samba share, and placed them on the desktop, windows will attempt to validate the path everytime the desktop is accessed (delete the shortcut).

If you opened documents, then there is a shortcut to the document in the resently used Documents list (clear this list out).

Jon
"Do or do not. There is no try!" - Yoda
Valued Contributor

Re: W2k trying to access a ghost share

Thank you for your suggestions. However, there has been (or is) no shortcuts to the network shares (other than the disconnected drive letter association), and the Documents list has been checked.

This is really getting me annoyed. Any other ideas?
Honored Contributor

Re: W2k trying to access a ghost share

There was a problem similar to this that was fixed in SP4. Are you up to date on Service Packs and hotfixes?

Jon
"Do or do not. There is no try!" - Yoda
Valued Contributor

Re: W2k trying to access a ghost share

Yes, I am. SP4 with all current updates.
Valued Contributor

Re: W2k trying to access a ghost share

Solved, finally!

I'm using Eudora, and I had tried starting it with the share name as a parameter (where to fetch the main environment). Therefore Windows registry contained some "Path#x" keys in HKEY_CURRENT_USER\Software\Qualcomm\Eudora\LaunchManager that contained the share names. (I didn't want to believe those would affect the problem.)

When I removed the share-pointing keys, responsiveness came back to my desktop!

This was quite surprising, as Eudora was not needed to be running for Windows to choke. Seemingly Windows checks some paths in the registry (under Eudora tree) when doing *anything* in the desktop.
//Add this to "OnDomLoad" event