Showing results for 
Search instead for 
Do you mean 

bl460c teaming issue

Occasional Advisor

bl460c teaming issue

hi,
we are using bl 460c blades with built-in 4 cisco ethernet switches..
each blade has 4 nic cards by default and each nic is directly connected to the cisco switches (each nic to a specific cisco switch).
now,all the 4 cisco switches are directly connected (2 ports from every cisco switch in internal ports 17+18) to our backbone switch "catalyst 4506" ,here is the built-in cisco configuration:

"interface Port-channel1

interface GigabitEthernet0/17
channel-group 1 mode on
!
interface GigabitEthernet0/18
channel-group 1 mode on"

now here is our cisco backbone 4506 configuration :
interface Port-channel10
description Connect to HP_Blade_Center
switchport
switchport access vlan 110
switchport mode access

interface GigabitEthernet4/36
switchport access vlan 110
switchport mode access
channel-group 10 mode on
!
interface GigabitEthernet4/37
switchport access vlan 110
switchport mode access
channel-group 10 mode on"
so we configured those configuration from each built-in cisco switch to our backbone..
so now i am asking :
1. for best performance this is the best configuration between cisco built-in switch to our cisco 4506 backbone ?
2. why i cannot perform windows teaming ? every time when i am trying to add members to teaming i am getting flipping errors from the hp cisco switch and network errors and i may lose connections to me blades ? what is wrong ?
3.for best performance in windows env (best mb/sec) which method of teaming i need ?

respectfully,
avi azerrad
7 REPLIES
Honored Contributor

Re: bl460c teaming issue

Hello,
What type on enclosure are you using? C3000 or C7000? How many blades are you using?
Occasional Advisor

Re: bl460c teaming issue

cx 7000
and internal built-in switch model "Model number : WS-CBS3020-HPQ"
Honored Contributor

Re: bl460c teaming issue

1 - Thats a good configuration to the upstream switch, 2GB etherchannel from each blade switch

2 - As far as I can see the ports 17 and 18 are on Vlan 1, not vlan 110 as the upstream switch ports, therefore the NICS wont be able to get the heartbeat of the team

3 - Since each NIC goes to a different switch, and the switch is not stacking capable, the options will be NFT or TLB team. Best option will be TLB, but is not possible to increase RX, it will only increase TX.

rgds
Occasional Advisor

Re: bl460c teaming issue

dear Lmm
my servers vlan name is 110 ,and the cisco built-in switch is directly connected to my backbone that are using vlan 110 ,in every cisco built-n switch (all the 4) ports 17-18 are directly connected to my backbone,here is the cisco built-in configuration:"
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
!
interface FastEthernet0
ip address 172.16.0.56 255.255.254.0
no ip route-cache
shutdown
!
interface GigabitEthernet0/1
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/2
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/3
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/4
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/5
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/6
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/7
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/8
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/9
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/10
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/11
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/12
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/13
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/14
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/15
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/16
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/17
channel-group 1 mode on
!
interface GigabitEthernet0/18
channel-group 1 mode on
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface Vlan1
ip address 172.16.0.56 255.255.254.0
no ip route-cache
!
interface Vlan10
no ip address
no ip route-cache
!
ip default-gateway 172.16.1.19
ip http server
snmp-server community public RO"

vlan 1 is only for the managment ip .

respectfully,
avi azerrad
Honored Contributor

Re: bl460c teaming issue

If the server vlan is 110, then the downlinks port where the servers are connected must be on that vlan:

interface GigabitEthernet0/6
speed 1000
switchport mode acess
switchport access vlan 110
spanning-tree portfas

and then you need to carry both vlan 1 and 110 to the upstream switch, which means the etherchannel must be a trunk (IEEE 802.1q):

interface GigabitEthernet0/17
Switchport mode truk
switchport trunk allowed vlan 1, 110 (Optional)
channel-group 1 mode on

Then it will carry traffic for both vlans, vlan 110 tagged, and vlan 1 unttaged since its the native vlan.

Same for the upstream switch ports where the
3020 is connecting to.

rgds,
Occasional Advisor

Re: bl460c teaming issue

hi,
i spoke today with HP ,the switch 3020 has no support to any teaming mode beside NLB while at this method only one nic is active,so they told me that if i want to use any other method i need to upgrade to 3120.
thank you for your fast support,
erspectfully,
avi azerrad
Occasional Advisor

Re: bl460c teaming issue

hi,
i spoke today with HP ,the switch 3020 has no support to any teaming mode beside NLB while at this method only one nic is active,so they told me that if i want to use any other method i need to upgrade to 3120.
thank you for your fast support,
erspectfully,
avi azerrad
//Add this to "OnDomLoad" event