cancel
Showing results for 
Search instead for 
Did you mean: 

enabling rlogin ?????

ln_unix
Frequent Advisor

enabling rlogin ?????

Hello All,

I need to enable rlogin in between 2 nodes i.e. node1 and node2....Could any one please help me...

Need simple steps to configure on both the nodes.

Always appreciate your help and support....

Best Regards,
LN
8 REPLIES
Michal Kapalka (mikap)
Honored Contributor
ln_unix
Frequent Advisor

Re: enabling rlogin ?????

Hello Mikap,

Very thanks for your reply...

but still after giving values in /.rhosts file,its asking me for password...

Can you please help on this.

One thing more---- is this can be the effect of ssh???? as ssh is configured on both the nodes...

Waiting for replies.....

Best Regards,
LN
Michal Kapalka (mikap)
Honored Contributor

Re: enabling rlogin ?????

hi,

yes it cvould by made a password less configuration via SSH.

mikap
ln_unix
Frequent Advisor

Re: enabling rlogin ?????

So, is there any solution to bypass ssh as am not able to remove ssh from the servers.
James R. Ferguson
Acclaimed Contributor

Re: enabling rlogin ?????

Hi:

> but still after giving values in /.rhosts file,its asking me for password...

You should read the 'hosts.equiv(4)' manpages to make sure your file follows protocol. You may need to put a fully-qualified hostname in addition to a simple hostname therein, too.

> One thing more---- is this can be the effect of ssh???? as ssh is configured on both the nodes...

This has nothing to do with 'ssh' and its configuration or lack thereof.

Using 'ssh' is a far superior way to perform remote operations. You should look to configuring password-less 'ssh' logins between trusted servers and jettison the 'rlogin' and 'remsh'.

Regards!

...JRF...
Bill Hassell
Honored Contributor

Re: enabling rlogin ?????

ssh has no relationship to the 'r' commands (rlogin, rcp, rexec and so on. The 'r' commands are not secure methods to communicate and are not recommended for today's systems. However, to get the .rhosts file to work, you need to put the remote user name and the remote system in the file. But because you probably have hostname problems, be sure to put the IP address as well as the fully qualified name in the file, like this:

node2 myname
node2.mydomain.com myname
12.34.56.78 myname

The file *MUST* be stored in the user's $HOME directory with permission 600, owned by the user.

And make sure the r commands are enabled in /etc/inetd.conf:

login stream tcp6 nowait root /usr/lbin/rlogind rlogind
shell stream tcp6 nowait root /usr/lbin/remshd remshd
exec stream tcp6 nowait root /usr/lbin/rexecd rexecd


Bill Hassell, sysadmin
ln_unix
Frequent Advisor

Re: enabling rlogin ?????

OK n Very Thanks to you Sirs,

Will check as per your suggestions and get back to you ....

But its time to leave the office...... :)

Very Thanks for replies :)

Best Regards,
LN
ln_unix
Frequent Advisor

Re: enabling rlogin ?????

DONE.. n thanks for the help and support from you all..it was a problem of FQDN...