cancel
Showing results for 
Search instead for 
Did you mean: 

entry in netconf

SOLVED
Go to solution
chindi
Respected Contributor

entry in netconf

hi guys,


i have to put the following entry in netconf file to keep it permanent....

10.34.32.0/255.255.255.0 10.32.32.6 UG 0 lan1 1500


whats is the entry that is to be made ; i made the following entry but its not working i.e after reboot the server doesnt come up with this entry... ...

ROUTE_DESTINATION[1]=10.34.32.0
ROUTE_MASK[1]=255.255.255.0
ROUTE_GATEWAY[1]=10.32.32.6
ROUTE_COUNT[1]=1


Please advice ...

13 REPLIES
AnthonySN
Respected Contributor

Re: entry in netconf

ROUTE_DESTINATION[1]="10.34.32.0"
ROUTE_MASK[1]=""
ROUTE_GATEWAY[1]="10.32.32.6"
ROUTE_COUNT[1]="1"
ROUTE_ARGS[1]=""

check by giving the below command
/sbin/init.d/net start

post the error you get if any.
Rita C Workman
Honored Contributor

Re: entry in netconf

hmm...mine generally looks something like this:

INTERFACE_NAME[x]="lan1"
IP_ADDRESS[x]="x.x.x.x"
SUBNET_MASK="0xffffff00" or 255.255.255.0
BROADCAST_ADDRESS[x]="x.x.x.x"
INTERFACE_STATE[x]=up
DHCP_ENABLE[x]=x 0 or 1 depending on you

ROUTE_DESTINATION[x]="default"
ROUTE_MASK[x]=""
ROUTE_GATEWAY="g/w addr"
ROUTE_COUNT[x]="1"

Now...that 1500 is likely the MTU speed, and that would go along with the entries you put in the /etc/rc.config.d/hp file. But to do that you need to know which one to use.
So run ioscan -fnC lan > ioscan.lan and see which file you need to edit based on the kind of lancard you have. (hpietherconf;hpigelanconf;hpbtlanconf...etc)

Hope that gives you some help..
Rita
Matti_Kurkela
Honored Contributor

Re: entry in netconf

You should read /etc/rc.log: if the route entry was rejected, there should be an error message. That message might help in finding out the problem.

In general, when setting up a new gateway route, the HP-UX system will reject the route unless it already can reach the gateway listed in the route specification, so the order of the route entries can be significant.

MK
MK
chindi
Respected Contributor

Re: entry in netconf

Hi Matti,

You were right i got the following error in my /etc/rc.log ,

Configure LAN interfaces
Output from "/sbin/rc2.d/S340net start":
----------------------------
ERROR: Failed to add route entry because its interface is not
yet initialized. May need to add this route entry with
a route commad after the interface is up :
netmask: bad value
"/sbin/rc2.d/S340net start" FAILED


Now how do i go ahead...

Hi SASJ,
I made the entry give by u ,

but what i got the result was ;
10.34.32.0/255.255.255.255 10.32.32.6 UGH 0 lan1 0

i need netmask as 255.255.255.0 ...

Kindly advice..
AnthonySN
Respected Contributor

Re: entry in netconf

as rita has mentioned above...


INTERFACE_NAME[x]="lan1"
IP_ADDRESS[x]="x.x.x.x"
SUBNET_MASK="0xffffff00" or 255.255.255.0
BROADCAST_ADDRESS[x]="x.x.x.x"
INTERFACE_STATE[x]=up
DHCP_ENABLE[x]=x 0 or 1 depending on you
sudheerch
Frequent Advisor

Re: entry in netconf

hi chindi

10.34.32.0/255.255.255.0 10.32.32.6 UG 0 lan1 0

#lanadmin- m 1 --> will show u the output
MTU Size - 0 right?

using #lanadmin u can change MTU Value to 1500

then the entrywhat u required will fulfill
Raj D.
Honored Contributor

Re: entry in netconf

Chindi,

If you are not familiar with the netconf file modification and the sequence, you can do it easily with sam as well:

- Copy the original default netconf file back to /etc/rc.config.d/ . Or comment all earlier entries .


- Identify the lan interface that is connected.
- go to # sam --> network configuration --> interfaces (choose the interface)
- From the Action menu --> choose modify network parameters. --> choose the lan#.
- Add the IP address & subnet mask. OK.
- exit one level --> go to Router parameter optin.
- Add route --> add the default route. OK.
- Exit SAM.
- # cat /etc/rc.config.d/netconf | grep -v ^# | awk /./ # review the entry.
- Reboot and verify.






B] Option B : With netconf :
You can comment other entries and add as per below: (replace lan8 and IP's accordingly , as per your lan number and IP.)

#/etc/rc.config.d/netconf

DEFAULT_INTERFACE_MODULES=""

IP_ADDRESS[1]=10.x.y.z
SUBNET_MASK[1]=255.255.255.0
INTERFACE_NAME[1]=lan8
BROADCAST_ADDRESS[1]=10.x.y.255
INTERFACE_STATE[1]=up

ROUTE_DESTINATION[0]=default
ROUTE_GATEWAY[0]=10.x.y.1
ROUTE_COUNT[0]=1




- Also, are you sure : 10.32.32.6 is your gateway IP. Gateway usually configured with the first IP of the subnet.



- Finally few more details may help here to find the actual problem: you can post:
# cat /etc/rc.config.d/netconf | grep -v ^# | awk /./

And : # lanadmin -sx 1






Good luck.
Raj.
" If u think u can , If u think u cannot , - You are always Right . "
chindi
Respected Contributor

Re: entry in netconf

Hi SASJ,


The problem is it shuld give me the subnet as 255.255.255.0 ...and not 255.255.255.255 ..which is the present case .


I hope now the problem is clear ....


chindi
Respected Contributor

Re: entry in netconf

Hi Raj,

My default route is fine...
i have to add another route....for 10.34.32.0 traffic...
Raj D.
Honored Contributor
Solution

Re: entry in netconf

Chindi,
For 10.34.32.0 traffic you can add another route to the netconf , remember to use uniqe number for the route entry,

- Manually you can do it and check with pinging the gateway:

1. # route add net 10.34.32.0 netmask 255.255.255.0 10.32.32.6 1

# The subnet mask seems to be ok with your network address, however you can check with your network design/support team if the netmask you are using is correct.



2.
- Once the above wroks well you can make it permanent by adding the lines to netconf:

You can add at the end of the netconf and you can check:

ROUTE_DESTINATION[1]="net 10.34.32.0"
ROUTE_MASK[1]="255.255.255.0"
ROUTE_GATEWAY[1]="10.32.32.6"
ROUTE_COUNT[1]="1"
ROUTE_ARGS[1]=""
ROUTE_SOURCE[1]=""


hth,
Raj.
" If u think u can , If u think u cannot , - You are always Right . "
chindi
Respected Contributor

Re: entry in netconf

Hi Raj,

I think you got it....dead right...

>>>> ROUTE_DESTINATION[1]="net 10.34.32.0"

I was looking for this entry ...the "net" word is imp here..

thanks i have edited my netconf file , and would be taking a reboot of this server asap...
Hope this entry would be permanent here...

Will keep u updated ....
Thanxx again...
chindi
Respected Contributor

Re: entry in netconf

As Raj rightly said it was the net word i was looking for...

thanx Raj after rebooting the server , the entry is still there....
sudheerch
Frequent Advisor

Re: entry in netconf

hi raj d

ROUTE_DESTINATION[1]="net 10.34.32.0"

what is the meaning of "net" in the above entry
what it will do