cancel
Showing results for 
Search instead for 
Did you mean: 

gateway pinging problem

bharat satsangi
Frequent Advisor

gateway pinging problem

Hi,
i have installed new system with 11.23 version,
i given all the required entry in /etc/rc.config.d/netconf (ip,netmask and gateway as 10.4.102.17,255.255.255.0,10.4.102.1) now i am not able to ping the gateway(10.4.102.1) from server itself.
Any one can guide me.
Thanks
8 REPLIES
Michael Steele_2
Honored Contributor

Re: gateway pinging problem

HI

a) Use 'set_parms initial' to configure the network on any HP-UX box.

b) ping hostname / ping your ip - Both OK? If yes then NIC is up and function.

c) netstat -rn - obtain gateway ip - ping default gateway. OK? If no then check cable connection.
Support Fatherhood - Stop Family Law
bharat satsangi
Frequent Advisor

Re: gateway pinging problem

I have set with set_parms initial, it gives the following error
WARNING: Unable to contact gateway at 10.4.102.1.

The gateway system may be down or there may be a network disruption.

Verify that the address 10.4.102.1 is correct.
Matti_Kurkela
Honored Contributor

Re: gateway pinging problem

Maybe your gateway has been configured to ignore any pings? Ask your network administrator.

If that's true, you must make sure HP-UX's "Dead Gateway Detection" feature is disabled.

For example, see this thread:
http://forums.itrc.hp.com/service/forums/questionanswer.do?threadId=182649

If Dead Gateway Detection was already triggered when you disable it, you may have to delete and re-add the gateway to the system's routing table, to get the route to work again:

route del default 10.4.102.1 1
route add default 10.4.102.1 1

MK
MK
bharat satsangi
Frequent Advisor

Re: gateway pinging problem

when i run
#route del default 10.4.102.1 1
del: unknown command
bharat satsangi
Frequent Advisor

Re: gateway pinging problem

the physical connection is ok, the other server is working fine on the same gateway which i installed 2 days back.the output of
netstat -rnv is

# netstat -rnv
Routing tables
Dest/Netmask Gateway Flags Refs Interface Pmtu
127.0.0.1/255.255.255.255 127.0.0.1 UH 0 lo0 4136
10.4.102.17/255.255.255.255 10.4.102.17 UH 0 lan2 4136
10.4.102.0/255.255.255.0 10.4.102.17 U 2 lan2 1500
127.0.0.0/255.0.0.0 127.0.0.1 U 0 lo0 0
default/0.0.0.0 10.4.102.1 UG 0 lan2 0

i am able to ping the ip but not gateway from server it self

thanks
Bill Hassell
Honored Contributor

Re: gateway pinging problem

The correct commands to delete and add the route are:

route delete default 10.4.102.1
route add default 10.4.102.1 1

Have you contacted your network administrator? Can they verify that a ping response is enabled for your gateway?

How about the basics? Run lanscan and look at the NamePPA. If there is only one LAN port used, then the PPA number is probably 0 (lan0). Run lanadamin and type these commands:

lanadmin
lan
ppa 0
display
quit

In the display listing, make sure that the Status lines are both UP:

Administration Status (value) = up(1)
Operation Status (value) = up(1)

If you see:
Operation Status (value) = down(2)

then the cable is not connected or the gateway port is dead or disabled.


Bill Hassell, sysadmin
Michael Steele_2
Honored Contributor

Re: gateway pinging problem

CHECK YOUR CABEL!!!!!!
Support Fatherhood - Stop Family Law
bharat satsangi
Frequent Advisor

Re: gateway pinging problem

.