Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

nfs mount error: Unknown authentication flavor #390004 for Windows server 2008 nfs share

SOLVED
Go to solution
Highlighted
TeresaY
Advisor

nfs mount error: Unknown authentication flavor #390004 for Windows server 2008 nfs share

Hi,

 

I was trying to mount a Windows share (hosted on Windows Server 2008) on my HP UX server. 

 

"showmount -e" returns correct info. However, the mount command returns this error:

 

    nfs mount: get_fh: Unknown authentication flavor #390004 for win_nfs_server:/nfshare

 

On Windows side, the Service for NFS  is using User Name Mapping (Active Directory Lookup is not used).

 

 

 

Thanks,

Teresa

4 REPLIES
Matti_Kurkela
Honored Contributor

Re: nfs mount error: Unknown authentication flavor #390004 for Windows server 2008 nfs share

Which version of HP-UX are you using? (What does the "uname -a" command report?)

 

The authentication flavor numbers are managed by IANA. Here is the official table:

http://www.iana.org/assignments/rpc-authentication-numbers/rpc-authentication-numbers.xml

 

According to that, flavor #390004 is krb5i. 

 

HP-UX 11.31 should be able to do that with NFS, but HP-UX 11.23 or older may not be able to.

MK
TeresaY
Advisor

Re: nfs mount error: Unknown authentication flavor #390004 for Windows server 2008 nfs share

Hi MK,

 

We are on B.11.11. We have no problems to mount NFS share on SFU 3.5 which resides on Windows Server 2003.

 

 

Thanks,

Teresa

TeresaY
Advisor
Solution

Re: nfs mount error: Unknown authentication flavor #390004 for Windows server 2008 nfs share

I was able to mount from HP UX after I changed one of the settings on "Server for NFS" on the Windows Server 2008:

 

Right click on Server For NFS-> Properties -> uncheck the option of "Enable NFS server 3 Support" -> Apply and restart the service.

 

 

 

Thanks,
Teresa

yisufr
Occasional Visitor

Re: nfs mount error: Unknown authentication flavor #390004 for Windows server 2008 nfs share

Using NFS by forcing the version to 2 will cause a several limitation on your file system, file ca not be greater than 4GB...

You can just uncheck the "integry and authentication Krb5i" on windows NFS server settings and retry.