Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

nfs mount: get_fh: RCP: program not registered

SOLVED
Go to solution
Yarok
Regular Advisor

nfs mount: get_fh: RCP: program not registered

Hello,

When tring to mount HPUX machine I received the above massege.

I run the following command:
mount IP_ADDRESS:/directory /HPUX machine name

As much as I know (and its very little) there is a file that defines that process and it can be confige there - /etc/inetd.conf then restart the process.
The problem is that I dont find the line to be edited.

Please advice.
Yaron
10 REPLIES
Ismail Azad
Esteemed Contributor
Solution

Re: nfs mount: get_fh: RCP: program not registered

Hi,

You are dealing with NFS is what I can figure out from your question and from the info that's given it looks like you are trying to mount an NFS filesystem on the client side. If this is the case, it has little to do with the /etc/inetd.conf file. I understand that there are few lines related to RPC in that file but I don't think that is the problem. Probably your NFS client functionality is disabled in /etc/rc.config.d/nfsconf...Check for NFS_CLIENT=1


> The problem is that I dont find the line to be edited.

I don't think you will find a line there if I have understood the question properly!

Regards
Ismail Azad
Read, read and read... Then read again until you read "between the lines".....
Yarok
Regular Advisor

Re: nfs mount: get_fh: RCP: program not registered

I'v changed it to = "1"

Should I reboot the sys or the is other way to make this change be valid?
Ismail Azad
Esteemed Contributor

Re: nfs mount: get_fh: RCP: program not registered

Hi yarok,

Try to start/stop the service. If you can surprsingly reboot do that. Mounting an NFS filesystem requires NFS client functionality enabled which seemed to disabled in your case. Try starting and stopping the following script. This might do the trick.

/sbin/init.d/nfs.client stop
/sbin/init.d/nfs.client start

You didn't tell us the O.S version. Check for this script. and if you are using a recent O.S the machine name on your mount command need not be there. It will mount the F.S on the server you are firing the command.

Regards
Ismail Azad
Read, read and read... Then read again until you read "between the lines".....
Yarok
Regular Advisor

Re: nfs mount: get_fh: RCP: program not registered

Hi,

I started/stoped the service. and still I cannot performe the mount. should I run it on the server as well?

The O.S version is r11.11/7 in this script.

bye the way I reply you and Mr. Dennis a massege regarding the auto mount issue and no one has responded.

Regards,

Yaron
Ismail Azad
Esteemed Contributor

Re: nfs mount: get_fh: RCP: program not registered

Hi,

You "share" on the server and "mount" on the client. What is the error you are getting while mounting?. The /HPUX in your command should be the client mount point. Is the IP address of the server correct and in your command the "directory" should be the filesystem/directory/file that is being shared. This is the logic behind the command you fired.

Regards
Ismail Azad
Read, read and read... Then read again until you read "between the lines".....
Yarok
Regular Advisor

Re: nfs mount: get_fh: RCP: program not registered

Ok,

Lets use names:

EREZ1 - is the server HPUX station.
VENUS2 - is the client HPUX station.

IP address client is correct.

the command i use on the server terminal is:

erez2# mount "client ip_address":/"directory" /venus2

Still the mount cannot be performed.
Ismail Azad
Esteemed Contributor

Re: nfs mount: get_fh: RCP: program not registered

Hi,

Is the NFS filesystem shared on the server?? And more imp is NFS server functionality enabled on your server?? You are working with a very old O.S since the client functionality was disabled by default or someone has changed it.

I am not sure what NFS version you are using but try these commands anyway...
showmount -e {I.P of server}
Check if F/S is shared.
If not share the F/S
share /directory , if this command isn't working try an "exportfs".

Then "mount" and if you are not able to mount what is the ERROR? Try a -F nfs option also with the mount command.

Regards
Ismail Azad
Read, read and read... Then read again until you read "between the lines".....
Yarok
Regular Advisor

Re: nfs mount: get_fh: RCP: program not registered

Hi,

>Is the NFS filesystem shared on the server??
>And more imp is NFS server functionality enabled on your server??

I dont Know how to see that.
I tried ps -ef | grep nfs (on the server) and I received a long list od /usr/sbin/nfsd from from the same day (30 Jan) and nfsktcpd as well.

>I am not sure what NFS version you are using but try these commands anyway...

venus2# showmount -e {I.P of server} shows

/scc (evryone)

>Check if F/S is shared.

how?

>If not share the F/S
share /directory , if this command isn't working try an "exportfs".

share command is not exist. I'v already ran exportfs and also with -a - didnt help.


>Then "mount" and if you are not able to mount what is the ERROR? Try a -F nfs option also with the mount command.

can you please write the exact command?

Regards,

Yaron
shanmuhanandam
Regular Advisor

Re: nfs mount: get_fh: RCP: program not registered

Hi,
Please go thro the doc.
http://docs.hp.com/en/5991-1154/5991-1154.pdf

Thanks,
Shan
Yarok
Regular Advisor

Re: nfs mount: get_fh: RCP: program not registered

Dear Ismail,

Please note that the problem is still there.
Did you receive my questions regarding to your last answer?

BR,

Yaron