cancel
Showing results for 
Search instead for 
Did you mean: 

problem with TFTP

SOLVED
Go to solution
Jose Juan
Advisor

problem with TFTP

Hi all

I've a problem with TFTP

In the /etc/inetd.conf:

tftp dgram udp wait root /usr/lbin/tftpd tftpd /home/tftpdir

In the /etc/passwd:

tftp:*:510:510:tftp server:/home/tftpdir:/usr/bin/false

I execute /usr/sbin/inetd -c

but when i try get a file i get "Transfer timed out."

In the syslog.log appear:

eb 22 10:55:39 grecods tftpd[14981]: No security mechanism exists; see tftpd(1M)
Feb 22 10:55:44 grecods tftpd[14984]: No security mechanism exists; see tftpd(1M)
Feb 22 10:55:49 grecods tftpd[14989]: No security mechanism exists; see tftpd(1M)
Feb 22 10:55:54 grecods tftpd[14992]: No security mechanism exists; see tftpd(1M)
Feb 22 10:55:59 grecods tftpd[14994]: No security mechanism exists; see tftpd(1M)

Where is the mistake?

Thanks in advance.
7 REPLIES
G. Vrijhoeven
Honored Contributor

Re: problem with TFTP

Hi,

1: the group membership should be guest.
2: Retransmission is defauld 5 secs and timeout is defaulted to 25 secs. If you have a bad connection you can alter these parameters with -R -T specifications (man tftpd)

Hope this will help,

Gideon
Jose Juan
Advisor

Re: problem with TFTP

In the file /etc/group:

guest::510:tftp

and the connections are very good
Ron Kinner
Honored Contributor

Re: problem with TFTP

No security mechanism exists
The pseudo-user tftp was not found in the password database (/etc/passwd), and tftpd was invoked without any path arguments.

Add or correct the entry for the pseudo-user tftp in the password database /etc/passwd. Or, add an access list (path arguments) to the tftpd arguments in the inetd configuration file /etc/inetd.conf. Reconfigure inetd with the command inetd -c.

If no path is specified on the command line, tftpd requires an entry in the /etc/passwd database (see passwd(4) ) for an account (pseudo-user) named tftp. The password field should be *, the group membership should be guest, and the login shell should be /usr/bin/false. For example (assuming the guest group ID is 101):

tftp:*:510:101:tftp server:/home/tftpdir:/usr/bin/false

Also verify that the /home/tftp directory exists and is rw.

Ron


Mark Greene_1
Honored Contributor
Solution

Re: problem with TFTP

in this line:

tftp dgram udp wait root /usr/lbin/tftpd tftpd /home/tftpdir

take out the /home/tftpdir reference, it is redundant because you have the tftp user defined.

then do the inetd -c thing to reread the config file.

HTH
mark
the future will be a lot like now, only later
Matthew Williams_3
Occasional Visitor

Re: problem with TFTP

I'm having the same problem. I've gone through the steps of {useradd tftp,groupadd guest,usermod -g guest ftp,passwd -r files -l tftp,mkdir /tftpboot,cp [a bunch of files] /tftpboot,chown -R tftp:guest /tftpboot,chmod 755 /tftpboot,chmod 644 /tftpboot/*,usermod -d /tftpboot tftp,echo /usr/bin/false>/etc/shells,chsh tftp /usr/bin/false}, which I believe should be everything required! "grep ^tftp /etc/inetd.conf" returns
"tftp dgram udp wait root /usr/lbin/tftpd tftpd", also. I get the same messages, however (yes, I have run inetd -c after all changes to inetd.conf)

Does there need to be something special with the guest group?

-os
Matthew Williams_3
Occasional Visitor

Re: problem with TFTP

Whoops! I had assumed that, because each log entry recorded a different pid, that every connection loaded a new copy of tftpd from scratch. It turns out that tftpd was still running and simply forking for each new connection; killing tftpd (and letting inetd restart it) fixed the problem.
bgwest
Occasional Advisor

Re: problem with TFTP

Ron,

Thanks for the post. The details here helped solve it.

In addition to this, I actually had to kill the tftpd. Although I created the user as active with guest /bin/false etc.. running inetd -c did not fully update the running config. After killing the process and restarting it with extended logging enabled (just in case it wasn't resolved yet), our syslog is finally free of that message. The poor tftpd just needed a home and now is at rest.

Benjamin G. West

"... I pass the hated wasteland with a grin, cause in the end I got my passions." -Aesop Rock