Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

remsh not working

tsunix-pdm-1
Advisor

remsh not working

Hi all,

 

I can`t remsh to a sytem (DEST)  from a server (SOURCE) ; I get a timeout. From other SOURCE server, I can do it.

 

- Both SOURCE servers exist in DEST's .rhosts

- Both SOURCE servers exist in DEST's inetd.sec

 

The DEST system have two IPs one belonging to its hostname and other one (2nd_IP), and I can see whenever I try:

 

SOURCE:/remsh DEST_hostname "uname -a"

 

..this in netstat -an:

 

Proto Recv-Q Send-Q  Local Address          Foreign Address        (state)

 

tcp        0      0          Hostname_IP.514          SOURCE_IP.1018       ESTABLISHED

tcp        0      1             <2nd_IP>.1023           SOURCE_IP.1017       SYN_SENT

 

 

So it seems I connect to it through its hostname BUT it returns through the 2nd lan; this is forbidden by the firewall. We have more systems with this configuration and they work well. Also, from other source servers, I can remsh to it without problems.

 

Any idea on what's going on and how to make remsh works?

 

Best Regards,

3 REPLIES
Torsten.
Acclaimed Contributor

Re: remsh not working

Are both IP addresses on the same server within the same subnet?

 

This is usually causing problems (unless you do some specific configurations).


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
tsunix-pdm-1
Advisor

Re: remsh not working

Yes, both IPs are on the same subnet. But "remsh" works from some servers, and we have servers with two IPs-same subnet and no problems seen. No idea on how to address this issue.

 

Best Regards,

Torsten.
Acclaimed Contributor

Re: remsh not working

There are a lot of related threads, example:

http://h30499.www3.hp.com/t5/Networking/about-ip-strong-es-model-and-lan-fail-over-redundancy/td-p/3922887

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!