cancel
Showing results for 
Search instead for 
Did you mean: 

remshd: Login incorrect.

Jenny John
Advisor

remshd: Login incorrect.

Hi All,

  i am trying to do rcp by the following command

[pap2]::/logic/users > rcp test_jen.txt jennyt@pap21:test_jen.txt

but its giving error

remshd: Login incorrect.

 

i have checked my .rhosts file it gt entry

pap1

 

What can be possible reason for this error.

 

Thanks in advance

6 REPLIES
pradeep m
HPE Pro

Re: remshd: Login incorrect.

 

Hi,

Make sure the .rhosts files in the destination servers be updated with the hostname of source server. 

 

[pap2]::/logic/users > rcp test_jen.txt jennyt@pap21:test_jen.txt

In your case, I suppose "pap2" is the source server and "pap21" is the destination server. In such case the .rhosts file in "pap21" should host the "pap2" entry. Update it if not and check if it works.  

 

If the issue still persists, check to see whether the remsh entry in /etc/inetd.conf contains the -l option (for example): 

     shell        stream tcp nowait root /usr/lbin/remshd   remshd -l 

 

Note:  -l   Disallow authentication based on the user's .rhosts file unless the user is a superuser.

If so, then remove the -l entry (for example): 
     shell        stream tcp nowait root /usr/lbin/remshd   remshd 

and tell inetd to reread the /etc/inetd.conf file: 
     inetd -c 

Check if it works now.  

 

Regards,
Pradeep

I am an HP Employee
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details


Jenny John
Advisor

Re: remshd: Login incorrect.

hi i have checked the .rhosts file in both servers and in /etc/inetd.conf

shell        stream tcp6 nowait root /usr/lbin/remshd   remshd

 

but still not working

Dennis Handly
Acclaimed Contributor

Re: remshd: Login incorrect.

Who is the source user?

What's the exact line in ~jennyt/.rhosts?

And the permissions for that .rhosts?

Bill Hassell
Honored Contributor

Re: remshd: Login incorrect.

You must have 600 permission on the .rhosts file, owned by jennyt. Also, the parent directory for .rhosts (HOME for jennyt) must not be world writable (755 or 750 would be OK). Then add the IP address to .rhosts for pap2. Network config errors may prevent rcp from working if pap2 cannot be resolved.



Bill Hassell, sysadmin
sdesh
Occasional Visitor

Re: remshd: Login incorrect.

Hi Pradeep,

 

My .rhosts file in the destination contains source server name with proper hostname of source server. 

 

Also  remsh entry in /etc/inetd.conf does not contain the -l option

 

 

But the problem still persists.

 

Please  help  !

Dennis Handly
Acclaimed Contributor

Re: remshd: Login incorrect.

>My .rhosts file in the destination contains source server name

 

FQDN?  In some cases I've had to use the IP address.