cancel
Showing results for 
Search instead for 
Did you mean: 

routing problem

mr_red
Advisor

routing problem

Hi guys,

 

I have a small problem here with my routing table.

I need to access a remote server (192.20.20.20) using ip 172.20.100.101 (lan5000). Here are the routing rules on my server :

 

# netstat -inw
Name              Mtu        Network         Address         
lo0               32808      127.0.0.0       127.0.0.1
lan5000:801       1500       172.20.100.0    172.20.100.131
lan5000:802       1500       172.20.100.0    172.20.100.121
lan5000           1500       172.20.100.0    172.20.100.101

 

# netstat -nrv
Routing tables
Dest/Netmask                    Gateway            Flags Refs Interface  Pmtu
127.0.0.1/255.255.255.255       127.0.0.1          UH    0    lo0       32808
172.20.100.121/255.255.255.255  172.20.100.121     UH    0    lan5000:802 32808
172.20.100.101/255.255.255.255  172.20.100.101     UH    0    lan5000   32808
172.20.100.131/255.255.255.255  172.20.100.131     UH    0    lan5000:801 32808
192.20.20.20/255.255.255.255    172.20.100.254     UGH   0    lan5000    1500
172.20.100.0/255.255.255.0      172.20.100.101     U     4    lan5000    1500
172.20.100.0/255.255.255.0      172.20.100.121     U     4    lan5000:802  1500
172.20.100.0/255.255.255.0      172.20.100.131     U     4    lan5000:801  1500
192.168.254.0/255.255.255.0     172.20.100.254     UG    0    lan5000    1500
127.0.0.0/255.0.0.0             127.0.0.1          U     0    lo0       32808
default/0.0.0.0                 172.20.100.254     UG    0    lan5000    1500
default/0.0.0.0                 172.20.100.254     UG    0    lan5000:802  1500
default/0.0.0.0                 172.20.100.254     UG    0    lan5000:801  1500

 

When I try to telnet the remote server i found that packets are using ip 172.20.100.131 (lan5000:801)

 

# telnet 192.20.20.20 1107

 

# tcpdump -ni 3 | grep "192.20.20.20"
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on lan5000, link-type EN10MB (Ethernet), capture size 65535 bytes
09:21:19.707496 IP 172.20.100.131.20651 > 192.20.20.20.1107: Flags [S], seq 3830382809, win 32768, options [mss 1460,wscale 0,nop], length 0

 

(I'm using telnet because ping is blocked)

 

Can someone help me to figure out the source of the problem because I don't see what i'm missing. (it's hpux 11.31)

 

Thank you!