cancel
Showing results for 
Search instead for 
Did you mean: 

subnet mask

Yaroki
Super Advisor

subnet mask

Hello,

 

I changed the subnet mask (via set_parms-> addl_netwrk) in order to work with another network. 255.0.0.0 to 255.255.0.0

I did this change for 2 HP-UX os types:

 

1. B.11.11 and change was just fine

2. B.10.20 and change didn't succeed. I can ping from both sides but cannot send files.

 

Any idea?

 

BR,

 

Yali.

3 REPLIES
Steven Schweda
Honored Contributor

Re: subnet mask

 
Yaroki
Super Advisor

Re: subnet mask

I will re-describe my problem.

 

In order to connect the HP-UX machines to another network (specific machine) I performed the following actions:

 

# set_parms addl_netwrk

I set the subnet mask parameter only from 255.255.255.0 to 255.255.0.0.

All the other parameters such as IP address, Local domain, DNS serve, NIS, have not been changed.

# reboot

# vi /etc/hosts

I add the requested machine (called vmb) to the the file with it's IP address.

# ping vmb

result: OK

Transferring files from vmb to HP-UX and the opposite way: OK

#net stat –rvn

Routing tables

Dest/Netmask                    Gateway            Flags   Refs Interface  Pmtu

127.0.0.1/255.255.255.255       127.0.0.1          UH        0  lo0        4136

IP_ADDRESS/255.255.255.255      IP_ADDRESS         UH        0  lan0       4136

8.12.0.0/255.255.0.0            IP_ADDRESS         U         2  lan0       1500

127.0.0.0/255.0.0.0             127.0.0.1          U         0  lo0        4136

default/0.0.0.0                 IP_ADDRESS         U         0  lan0       1500

 

 

 

All the above refer to HP-UX B.11.11.

 

 

The same actions performed to HP-UX B.10.20 as follow:

I set the subnet mask parameter only from 255.255.255.0 to 255.255.0.0.

All the other parameters such as IP address, Local domain, DNS serve, NIS, have not been changed.

# reboot

# vi /etc/hosts

I add the requested machine (called vmb) to the the file with it's IP address.

# ping vmb

Result: OK

Transferring files from vmb to HP-UX and the opposite way: NOT OK

 #netstat –rnv

Routing tables

Dest/Netmask    Gateway         Flags   Refs     Use  Interface  Pmtu PmtuTime

IP_ADDRESS/255.255.255.255

                127.0.0.1       UH        74 6194188  lo0        4608

127.0.0.1/255.255.255.255

                127.0.0.1       UH         6    1087  lo0        4608

default/0.0.0.0 8.12.4.16       UG         0       0  lan0       1500

8.12/255.255.0.0

                IP_ADDRESS       U         62 1177403  lan0       1500

 

Does it concern to the old HP-UX version - B.10.20 (and it's network_card)?

Please advice 

Steven Schweda
Honored Contributor

Re: subnet mask