cancel
Showing results for 
Search instead for 
Did you mean: 

telnet is not working

SOLVED
Go to solution
bharat satsangi
Frequent Advisor

telnet is not working

Hi,
i am running HP-UX amdb01 B.11.23 U ia64 2321177401 unlimited-user license.
i am not able to telnet on it however i am able to ssh on it.
i have checked /etc/inetd.conf the entry is there and uncommented, i have also checked /etc/services its also fine.
when i am checking for ps -ef | grep telnetd there is no process.
please help me to get it done.
Thanks.
12 REPLIES
Jupinder Bedi
Respected Contributor

Re: telnet is not working


To start telnetd from the Internet daemon, the configuration file
/etc/inetd.conf must contain an entry as follows:

telnet stream tcp nowait root /usr/lbin/telnetd telnetd

than run /usr/sbin/inetd -c

if still not working please send me the following output

/var/adm/syslog/syslog.log
All things excellent are as difficult as they are rare
Jupinder Bedi
Respected Contributor

Re: telnet is not working

also check if port 23 is listening or not

#netstat -an |grep LISTEN |grep 23
tcp 0 0 *.23 *.* LISTEN
All things excellent are as difficult as they are rare
bharat satsangi
Frequent Advisor

Re: telnet is not working

following is the output of /var/adm/syslog/syslog.log

Feb 10 18:46:57 amdb01 inetd[1250]: Rereading configuration
Feb 10 18:46:57 amdb01 inetd[1250]: Configuration complete
Feb 10 18:42:09 amdb01 cimserver[2016]: PGS17200: Authentication failed for user root.
Feb 10 18:47:05 amdb01 above message repeats 3 times
Feb 10 18:47:07 amdb01 cimserver[2016]: PGS17200: Authentication failed for user root.
Feb 10 18:48:36 amdb01 telnetd[25060]: tcgetattr(TCGETA): Not a typewriter
Feb 10 18:48:36 amdb01 telnetd[25060]: ioctl(TCSANOW): I/O error
Feb 10 18:48:36 amdb01 vmunix: tunwrput(0): M_DATA for unconnected stream
Feb 10 18:47:09 amdb01 cimserver[2016]: PGS17200: Authentication failed for user root.
Feb 10 18:48:46 amdb01 telnetd[25118]: tcgetattr(TCGETA): Not a typewriter
Feb 10 18:48:46 amdb01 telnetd[25118]: ioctl(TCSANOW): I/O error
Feb 10 18:49:13 amdb01 telnetd[25340]: tcgetattr(TCGETA): Not a typewriter
Feb 10 18:49:13 amdb01 telnetd[25340]: ioctl(TCSANOW): I/O error
Horia Chirculescu
Honored Contributor

Re: telnet is not working

>when i am checking for ps -ef | grep telnetd there is no process.

If you said that you have choosed to run telnetd from inetd, there should be no telnetd process except for the period you actually have one telnet client connected. If you would set up telnetd as stand alone, you would always see that daemon running.

If you say that you did what it takes (regarding telnetd) in /etc/inetd.conf, then maybe you forgot to run a

/usr/sbin/inetd -c

in order to let inetd re-scan the configuration file and re-configure itself.

Horia.
Best regards from Romania,
Horia.
bharat satsangi
Frequent Advisor

Re: telnet is not working

following is the output and its LISTEN
amdb01#netstat -an |grep LISTEN |grep 23
tcp 0 0 *.2301 *.* LISTEN
tcp 0 0 *.23 *.* LISTEN
tcp 0 0 *.62308 *.* LISTEN
tcp 0 0 *.49239 *.* LISTEN

and /etc/inetd.conf also contain a entry as
telnet stream tcp nowait root /usr/lbin/telnetd telnetd

then i have also ran /usr/sbin/inetd -c
stll i am not able to do telnet.
R.K. #
Honored Contributor

Re: telnet is not working

Hello Bharat,

Please check following:
# telnet 0
# lsdev | grep -i tel
# ll /dev/telnetm
# lssf /dev/telnetm
Telnet patch level.

You can compare above outputs with any working server.

Regds
Don't fix that what ain't broke
bharat satsangi
Frequent Advisor

Re: telnet is not working

Hi,
following is the output of all the commands
amdb01#telnet 0
Trying...
Connected to 0.
Escape character is '^]'.
Local flow control on
Telnet TERMINAL-SPEED option ON

HP-UX amdb01 B.11.23 U ia64 (ta)

Connection closed by foreign host.



amdb01#lsdev | grep -i tel
95 -1 tels strtels
96 -1 telm strtelm




amdb01#ll /dev/telnetm
crw-rw-rw- 1 root sys 72 0x000060 Feb 10 19:21 /dev/telnetm



amdb01#lssf /dev/telnetm
streams cloneable pseudo driver telm /dev/telnetm



still iam not able to telnet on to the system
R.K. #
Honored Contributor

Re: telnet is not working

Hello Again,

What do you get when you do:
# telnet
like Connected to..

You can also try to enable inetd logging and then check syslog.log:
# inetd -l
# tail -f /var/adm/syslog/syslog.log
Now telnet the server and see what fresh is logged in syslog.log

Regds..
Don't fix that what ain't broke
Jupinder Bedi
Respected Contributor

Re: telnet is not working

Do one thing...


cd /etc
mv securetty securetty.old

and than try

Good luck
All things excellent are as difficult as they are rare
R.K. #
Honored Contributor
Solution

Re: telnet is not working

Hi Again,

Also try installing special files:

# insf -v -d tels
or
# insf -eC pseudo

And yes...do check the presence of securetty file as pointed above.

Regds..
Don't fix that what ain't broke
bharat satsangi
Frequent Advisor

Re: telnet is not working

Hi,
Thanks a lot my problem is solved.
bharat satsangi
Frequent Advisor

Re: telnet is not working

.