Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Networking
cancel
Showing results for 
Search instead for 
Did you mean: 

wireshark (software.hp.com) and libpcre.so

SOLVED
Go to solution
Doug O'Leary
Honored Contributor

wireshark (software.hp.com) and libpcre.so

Hey;

 

Just downloaded wireshark/libpcap from software.hp.com.  Both installed w/o issue.  When I go to run it, I'm getting:

 

wireshark
/usr/lib/hpux32/dld.so: Unable to find library '/usr/local/lib/hpux32/libpcre.so'.
Killed

 

i scanned the whole system - sure enough, no libpcre.so anywhere on the box.  Am I missing a package or is software.hp.com borked?

 

One other thing: does anyone know of an nmap depot other than the one on the UK porting center (the one with 8 gazillion dependencies?)

 

Any help greatly appreciated.

 

Thanks.


------
Senior UNIX Admin
O'Leary Computers Inc
linkedin: http://www.linkedin.com/dkoleary
Resume: http://www.olearycomputers.com/resume.html
9 REPLIES
Patrick Wallek
Honored Contributor

Re: wireshark (software.hp.com) and libpcre.so

Have a look at the following thread:

http://h30499.www3.hp.com/t5/Networking/Wireshark-error/td-p/.UMpCaoNX01I

 

It appears that you may not have all of the necessary dependencies installed.

 

 

Doug O'Leary
Honored Contributor

Re: wireshark (software.hp.com) and libpcre.so

Hey;

 

Thanks for the reply.  When I hit that link, I'm getting an error stating "An invalid set of parameters has been specified in the url."  Does it say what the dependencies for the ixpress wireshark are?  I thought that was one of the bigger benefits of software.hp.com; not having to download all the separate packages as we do if we use the porting centers.

 

I just looked through the install doc for iexpress.  It doesnt' mention any dependencies.  There is a "system requirements" link, but that, too, is invalid.  

 

Thanks.

 

Doug


------
Senior UNIX Admin
O'Leary Computers Inc
linkedin: http://www.linkedin.com/dkoleary
Resume: http://www.olearycomputers.com/resume.html
Patrick Wallek
Honored Contributor

Re: wireshark (software.hp.com) and libpcre.so

If you download from the HP Software porting and archive centre it will list all the dependencies.

 

Try this link:

http://hpux.connect.org.uk/hppd/hpux/Gtk/Applications/wireshark-1.8.4/

Duncan Edmonstone
Honored Contributor
Solution

Re: wireshark (software.hp.com) and libpcre.so

Doug,

 

>>  I thought that was one of the bigger benefits of software.hp.com; not having to download all the separate packages as we do if we use the porting centers.

 

I thought that as well, although it appears to not be the case for Wireshark for some reason - I note the following in the file /opt/iexpress/wireshark/README.hp

 

Note:Before installing Wireshark depot make sure that below mentioned dependent products are already installed on your machine , either you can compile them by yourself or you
can get the compiled version from  http://hpux.connect.org.uk/

Without these dependent products wireshark will not work properly on Itanium machine, so please install them before installing wireshark depot on IA[For PA RISC no need to inst
all dependent depots].

Dependent Products and The site to download Compiled Version OF Them:

  gtk+       (http://hpux.connect.org.uk/)
  glib       (http://hpux.connect.org.uk/)
  libiconv   (http://hpux.connect.org.uk/)
  gettext    (http://hpux.connect.org.uk/)
  flex       (http://hpux.connect.org.uk/)
  libpcap    (http://hpux.connect.org.uk/ or Internet Express)
  pcre       (http://hpux.connect.org.uk/)
  zlib       (http://hpux.connect.org.uk/ or Internet Express)
  GNU adns
  # For IPF 11.23 only
  X11R6incs  (http://hpux.connect.org.uk/)

 Maybe worth emailing the Internet Express team at hpux.iexpress@hp.com to ask them why this is the case for Wireshark? Maybe just too many dependencies?

 


HTH

Duncan
Doug O'Leary
Honored Contributor

Re: wireshark (software.hp.com) and libpcre.so

Hey;

 

Outstanding.  Thanks for pointing that out.  As I mentioned, I ran through the all the web pages looking for something like that.  Should have known that there'd be a readme with the installed bits.

 

Any rate, tcpdump works so, if push comes to shove, I'll just record the data using tcpdump, then scp the pcap files to a linux box where apt or yum *will* install all the prereqs along with wireshark :)

 

Thanks again.  I appreciate it.

 

Doug O'Leary


------
Senior UNIX Admin
O'Leary Computers Inc
linkedin: http://www.linkedin.com/dkoleary
Resume: http://www.olearycomputers.com/resume.html
Duncan Edmonstone
Honored Contributor

Re: wireshark (software.hp.com) and libpcre.so

>> ...where apt or yum *will* install all the prereqs along with wireshark :)

 

Have you looked at depothelper? That will pick up all the required dependencies as well if you install Wireshark from hpux.connect.org.uk :

 

http://hpux.connect.org.uk/hppd/hpux/Sysadmin/depothelper-2.00/


HTH

Duncan
Doug O'Leary
Honored Contributor

Re: wireshark (software.hp.com) and libpcre.so

Hey;

 

I did not know about depothelper.  That'll make my life *significantly* easier.  thank you very much!

 

Doug O'Leary


------
Senior UNIX Admin
O'Leary Computers Inc
linkedin: http://www.linkedin.com/dkoleary
Resume: http://www.olearycomputers.com/resume.html
Doug O'Leary
Honored Contributor

Re: wireshark (software.hp.com) and libpcre.so

Hey;

 

Unintentionally hijacking my own thread, but I tried this:

 

# depothelper -a ia64 -o 11.31 -c /ignite/temp -n nmap-4.76
================================================================
Package-version Comment Download Install
================================================================
ia64-11.31 Package list FAILED Not installed
================================================================
ERROR: Can't get list of ia64-11.31 packages from hpux.connect.org.uk - aborted

 

The system does have a direct/non-proxied connection.  I was able to use wget to get the depothelper depot directly from hpux.connect.org.uk.  

 

From my reading of the man page, this looks right.  Am I doing something wrong or is there something amiss with the UK porting center?

 

Thanks.

 

Doug O'Leary


------
Senior UNIX Admin
O'Leary Computers Inc
linkedin: http://www.linkedin.com/dkoleary
Resume: http://www.olearycomputers.com/resume.html
Doug O'Leary
Honored Contributor

Re: wireshark (software.hp.com) and libpcre.so

Hey

 

never mind; Found the ftp command in the depothelper script and ran it manually... they do have ftp proxied.  

 

Thanks.


------
Senior UNIX Admin
O'Leary Computers Inc
linkedin: http://www.linkedin.com/dkoleary
Resume: http://www.olearycomputers.com/resume.html