Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
Operating System - Microsoft
cancel
Showing results for 
Search instead for 
Did you mean: 

Application Error on HPPerfProv.dll

KarenML
Occasional Contributor

Application Error on HPPerfProv.dll

I am receiving the following (Event ID 1000) error on a Windows 2008 SP1, two node Failover Cluster (both nodes exhibit the error). The nodes are running on HP BL25P G1 Servers connected to an EVA 4000. All components in this configuration are at the latest versions, including the PSP (8.10A).
The error text is:
Faulting application WmiApSrv.exe, version 6.0.6001.18000, time stamp 0x47918d17, faulting module HPPerfProv.dll, version 1.0.3.6, time stamp 0x4289d46a, exception code 0xc0000005, fault offset 0x00001fb0, process id 0x1348, application start time 0x01c8f18350927132.

This message is immediately followed by a WMI error (Event ID 10):
Event filter with query "select * from HP_AlertIndication" could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041010. Events cannot be delivered through this filter until the problem is corrected.

The only time these errors occur is following a server reboot. I researched the Event 10 issue on the Microsoft site at http://technet2.microsoft.com/windowsserver2008/en/library/cf4951cd-d116-49c9-b617-c6dd7ce834f21033.mspx?mfr=true and investigated the steps for resolution. The WMI Event Registration Event component involved is WbemEventConsumer.Name="HPSIM_. I cannot determine if the issue is significant, as the servers show green status in HP SIM (C.05.02.01.00). However, it was suggested that the vendor (in this case, HP) must be contacted for resolution. I have been unable to find related information for this issue in the HP Resource Center. Any assistance is appreciated. Thank you.

8 REPLIES
SteveMacNZ
Occasional Advisor

Re: Application Error on HPPerfProv.dll

I am also getting the same error on 9 BL460c blades running Windows 2008 SP1, in a mixture of Standard and Enterprise editions, 4 of these servers are running Microsoft Active Standby clusters the others are just standard member servers. I have tried both PSP 8.0 and 8.10A. The error text is:
"Faulting Application WmiAPSrv.exe, version 6.0.6001.18000, time stamp 0x47918d17, faulting module HPPerfProv.dll, version 1.0.3.6, time stamp 0x4289d46a, exception code 0xc0000005, fault offset 0x00001fb0, process id 0x148c, application start time 0x01c8fdc69c2ecc71."

However I am not getting the WMI error (Event ID 10) as above I am getting the following:
log Name: System Source: Service Control Manager Event Event ID: 7031
"The WMI Performance Adapter service terminated unexpectedly. It has done the 1 time(s). The following corrective action will be taken in 120000 milliseconds; Restart the service."

I have rung HP Technical Support and they were unable to find anything on this.
KarenML
Occasional Contributor

Re: Application Error on HPPerfProv.dll

Thanks, Steve. I neglected to mention that my Windows 2008 server is 32-bit standard version.
Sean van Osnabrugge
Occasional Visitor

Re: Application Error on HPPerfProv.dll

I am experiencing the exact same issue on Windows Server 2008 Enterprise Edition (64-bit). PSP 8.10A is installed. Our hardware is BL460c G1 connected to an EVA6000.

If someone from HP could update this posting with information in regards to the significance of this error and/or if a fix will be made.

Thanks.
matt051074
Occasional Advisor

Re: Application Error on HPPerfProv.dll

I found this on the net. You can try it and see what happens. Seems like a driver conflict that win perfmon loads and the HPP driver.

DLL Named "HPPerfProv.dll". This schould be a DLL File which is loaded by Windows Perfmon.... Renemae the DLL in "HPPerfProv.dll.old" Reboot the System and all works fine!
Carlos Carrolo
Occasional Visitor

Re: Application Error on HPPerfProv.dll

Hi All,

My customer has reported to me the same issue. On first analyse, it sounds that the the installation of the HP MPIO DSM on his W2K8 Server has not correctly register under the CIMV2 the class for the HP Monitoring tool. As a consequence, we are unable to found the Win32_PerfFormattedDatat_XXX class under the Root\CimV2. This issue should be investigate from HP.
My customer has finally apply the HP MPIO DSM 3.01.00 (dated from 19 August 2008) and problem is now solved: No more Evt 1000 and using the perfmon /wmi, HP Counters are present and working.

Regards.

Carlos Manuel Carrolo
Windows Core - Support Engineer
EMEA Global Technical Support Center | Microsoft Product Support Services
SteveMacNZ
Occasional Advisor

Re: Application Error on HPPerfProv.dll

I have organised to install this update today (HP MPIO DSM 3.01.00) will advise if this fixes the issue as well.

Steve:)
Roger Faucher
Honored Contributor

Re: Application Error on HPPerfProv.dll

Just a reminder to everyone that there is now a Windows Server 2008 thread.

Make a great day!

Roger
Make a great day!

Roger
Ste7ios
Occasional Visitor

Re: Application Error on HPPerfProv.dll

I also have a similar problem on a Win2K8 64-bit SP1.

The error is:

Faulting application WmiApSrv.exe, version 6.0.6001.18000, time stamp 0x4791951b, faulting module HPPerfProv.dll, version 1.0.5.6, time stamp 0x4289d276, exception code 0xc0000005, fault offset 0x00000000000026a7, process id 0x1108, application start time 0x01c97f2041857514.

The server is connected to an EVA8100 and we use MPIO and the VSS Hardware Provider.