Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Microsoft
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot boot my HP520c - Hangs after amdagp.sys

Subhash Mahajan
Occasional Visitor

Cannot boot my HP520c - Hangs after amdagp.sys

My computer was responding slow. Upon Restart, I could not reboot to a prior good configuration. Even the SAFE MODE did not work. It hangs after loading amdagp.sys.

It is a refurberished m/c, and I don't have a boot disk/cd either.

The m/c does not have a separate video card either.

I will appreicate any help.

Thanks.
Subhash

scma
4 REPLIES
Roger Faucher
Honored Contributor

Re: Cannot boot my HP520c - Hangs after amdagp.sys

Subhash:

I assume this is a WINXP system. First, I would go into the BIOS Setup program and reset it to defaults. If that doesn't solve the problem, I might be inclined to upgrade the BIOS from here:

http://h20015.www2.hp.com/en/softwareList.jhtml?reg=&cc=us&prodId=hppavilion70996&lc=en&plc=&softitem=Microsoft%20Windows%20XP&sw_lang=en&pagetype=software

Alternatively, I would "refresh" Windows this way:

http://support.microsoft.com/default.aspx?scid=kb;en-us;315341&Product=winxp

HTH

Roger
Make a great day!

Roger
Michael Dillman
Valued Contributor

Re: Cannot boot my HP520c - Hangs after amdagp.sys

Additionally, if you can get to the startup menu where you would select safe mode, try starting in debugging mode.
If at first you don't succeed, you must be installing Windows
Mike_665
Frequent Advisor

Re: Cannot boot my HP520c - Hangs after amdagp.sys

You could try removing the battery on your mother board then put it back in, then try to reboot. Hope this helps.

M
Ramesh Pakkath
Honored Contributor

Re: Cannot boot my HP520c - Hangs after amdagp.sys

Hi Subash,

All you need to do is delete AMDAGP.sys and reinstall the video drivers.
Nothing is "imPOSSIBLE"