Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
Operating System - Microsoft
Showing results for 
Search instead for 
Did you mean: 

Here's a hard one folks!

Michael Brooks_4
Occasional Advisor

Here's a hard one folks!

I just installed oracle 8.1.7 on my PC on a Windows NT.
I already had oracle 8.0.6 on the system with Oracle 6i designer. The problem is now none of the Oracle designer stuff or Sql-Nav or Sql-plus works. I get these errors now:
Ora-01034: oracle not available
Ora-27101 shared memory realm does not exist.

Please help me correct this, Iâ ve worked on this all day without results.

Thanks so very much,
Honored Contributor

Re: Here's a hard one folks!

I assume you are talking abt oracle on HP-UX.

I had come accross these errors sometime back.

It seems that the SID_instance name used to bring down oracle was not set properly.

Check for any processes that are oracle processes and kill everything.

Also with ipcs check if you have nay non-attached shared memory segments, if any(natth value 0) remove them with ipcrm and tray again.

Post the results.
There is no substitute to HARDWORK
Steven E. Protter
Exalted Contributor

Re: Here's a hard one folks!

There is a specific migration procedure for designer databases that must be followed. If you don't follow the conversion procedure the repository won't work. or

Steven E Protter
Owner of ISN Corporation
Michael T. Boduch
Occasional Advisor

Re: Here's a hard one folks!

Check to be sure that the oracle executable (and sqlplus for that matter) are chmod 6755. The database allocates shared memory but it cannot be shared by dedicated server processes unless the suid bit is set on the executable. I've been burned by this (same error messages) in the past. It may or may not be your root problem.
Indira Aramandla
Honored Contributor

Re: Here's a hard one folks!

Hi Michael,

The errors, 1034 and 27101 indicate the ORACLE_HOME or ORACLE_SID is not set properly or pointing to an oracle_home that exists, but is not the correct one. Also ensure that the installation was complete without any errors by looking up the InstallActions.log and OraInstall.err file.

Start up SVRMGRL.
Go ahead and run a SHUTDOWN IMMEDIATE (if it already is not shut down).

No go ahead and do a startup

SVRMGRL> STARTUP pfile=c:Oracle\Admin\sid_name\pfile\init.ora
See what kind of results you get then.

If you still have the same problem then recheck your memory settings. For some reason, you instance isn't able to allocate memory at startup.

This error message also indicates that the SGA did not initialize (i.e., the database is not started.) If you started the DB, then look in the alert log for clues as to why it did not initialize the SGA.

Did you use a tnsname when you were trying to connect?
sqlplus username/password@tnsname

If not, Oracle was looking for a database running against the ORACLE_HOME in which you were running SQL*Plus from. It didn't find a running database, hence the error.

Or if you are ⠦⠦⠦⠦⠦⠦⠦ attempting to connect to an Oracle8i database from a client using sqlplus and receive the following errors:

ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
SVR4 Error: 2: No such file or directory

You have installed 8.1.7 on the same server in a seperate ORACLE_HOME.

Possible Solution would be :-

1) For local (BEQ/IPC) connections:

Verify that the ORACLE_SID environment variable is set and points to a valid
8.1.7 database that is up and running.

2) For remote (TCP/listener) connections:

Review the listener.ora currently used to startup the listener and verify the ORACLE_HOME value is correct for all listed Oracle8i databases.
If the ORACLE_HOME points to the 8.1.7 software, however the database was
created using a different version (e.g. 8.1.6 or 8.1.5), then this error can occur.


Previously, when the ORACLE_HOME or ORACLE_SID were set incorrectly, in the
'oracle' or client user's environment, only ora-1034 was reported e.g.:

ORA-01034 "ORACLE not available"

With 8.1.7, error ORA-27101 reports that the shared memory key generated by the
client does not match any currently existing keys. This is to be expected if the ORACLE_HOME used by the client is not the same as that used to startup the
database or when the ORACLE_SID value is not correctly referencing the right

Never give up, Keep Trying
Honored Contributor

Re: Here's a hard one folks!


you can try to change your ORACLE_HOME by running the following program:
"..\Program Files\Oracle\oui\HomeSelector\ohsel.exe"

hope this helps too!

No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
R. Allan Hicks
Trusted Contributor

Re: Here's a hard one folks!

I hope you installed the 8.1.7 in a separate Oracle Home. If so, youreeaj recommendation to switch oracle homes should work fine.

One minor point. You may need to check your sysadmin services to make sure that the older copy is running.
"Only he who attempts the absurd is capable of achieving the impossible
Michael Schulte zur Sur
Honored Contributor

Re: Here's a hard one folks!


had? Does this mean, it is gone? Check the environment variables besides ORACLE_SID and ORACLE_HOME also TNS_ADMIN, which points to the network\admin. If you have uninstalled Oracle 8.0.6 there might be leftovers in the registry.