Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Operating System - Microsoft
Showing results for 
Search instead for 
Did you mean: 

USB misbehaving on DL360/G5 servers

Occasional Contributor

USB misbehaving on DL360/G5 servers

I am currently experiencing a USB problem on a pair of DL360/G5 servers. We use a rack-mounted caddy which holds two removeable hard drives; they are both directly connected to the two USB ports at the rear of the G5 server via USB cables. We use the same solution on many other HP servers without problem. Here goes... When the first drive is inserted into its rack, USB detects it as a mass storage device and we can use it ok, but when we remove it and try to insert another one, the mass storage device displays a yellow alert and a code 38, saying the driver is still installed from a previous incarnation. A reboot is needed to solve this. We have tried alsorts of things but the curious conclusion is that we can only get an RHD to work correctly (hot swap/plug and play) when it is NOT the first MSD listed under USB. So, if we put a USB memory stick in the front USB port first (so that is the first MSD listed) then both RHDs can be used perfectly well, in and out all day - or even if two RHDs are inserted, provided the first one is left alone, the second one can be swapped and used SO LONG AS THE FIRST MSD is not moved. As soon as it is, then the problem recurs. I have tried many things, including uninstalling and reloading the USB drivers, disabling legacy USB, disabling iLO, disconnecting the external storageworks box,clearing out the mounteddevices registery key - all to no avail. Has anybody got any ideas !? Thanks

James ~ Happy Dude
Honored Contributor

Re: USB misbehaving on DL360/G5 servers

Code 38
Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory. (Code 38)

Recommended resolution

The driver could not be loaded because a previous instance is still loaded. Restart the computer.

On the General Properties tab of the device, click Troubleshoot to start the Troubleshooting Wizard.

Not much luck with the error;
Occasional Contributor

Re: USB misbehaving on DL360/G5 servers

Obviously, rebooting is the standard work-around, and I'm fairly sure I ran the troubleshooter to no avail. I'll check it again. What is so odd is that it works fine PROVIDED you keep the first MSD plugged-in, so when you push and pull MSD 2 and 3, there is no problem with the driver no been released from memory.